Views: 10641
Number of votes: 3
Average rating:

Enabling EPiServer CMS 6 VS Integration in Visual Studio 2010

In this blog entry Fredrik Tjärnberg described how to enable EPiServer CMS 5 R2 VS Integration in Visual Studio 2010.

I’m happy to report that this trick works just as well with EPiServer CMS 6 VS Integration. You just need to replace all references to 5.2.375.226 in the blog with 6.0.530.0 instead.

If by some chance you only have Visual Studio 2010 installed and not 2008 then of course CMS 6 VS Integration cannot be installed (as it only officially targets 2008). In this case you can download the components you need here. Copy the contents of the zip file to the %ProgramFiles%\Microsoft Visual Studio 10.0\Common7\IDE\ folder on the target computer.

Please note that this information and the accompanying zip file are provided ‘as is’ without warranty or guarantee. EPiServer CMS does not officially support VS Integration in Visual Studio 2010 or running EPiServer CMS applications in a  .NET 4 runtime environment.

May 05, 2010

Guest
(By Guest, 9/21/2010 12:33:19 PM)

You also need to add EPiServer.VsIntegration to the GAC in order to make it work.
/ Sören Helenelund

himanshu.chawla
(By himanshu.chawla, 9/21/2010 12:33:19 PM)

Hi

Where I can find EPiServer.VsIntegration ??

Jeff.Wallace
(By Jeff.Wallace, 9/21/2010 12:33:19 PM)

Himanshu, if you download the CMS version of your choice the msi for installing the VS integration should be included in the .zip file.

http://world.episerver.com/Download/Categories/Products/EPiServer-CMS/

john.walsh
(By john.walsh, 9/21/2010 12:33:19 PM)

I'm not going to take any credit for this because it was a collegue that pointed me in the right direction. Plus with some googling you can find it yourself. Here's how to install the EPiServer.VSIntegration.dll when you have a new computer (Windows 7) and only installed visual studio 2010 (like we did):

* After doing everything Paul and Fredrik have written about it still wont work and as Sören rightly states

* First you need to get a tool to extract the files from EPiServerVsIntegration.msi. We used lessmsi (less msierables) by Scott Willeke - found here on his blog: http://blog.scott.willeke.com/2009/12/updated-lessmsi-less-msierables-utility.html

* After extracting the files and finding the EPiServer.VSIntegration.dll in the folder "EPiServer CMS 6 VS Integration Files\SourceDir\PFiles\EPiServer\CMS\6.0.530.0\VSTemplates" you need to add it to the GAC.

* One way to add to the GAC is to run the Visual Studio Command Prompt (2010) - run as administrator of course and run the gacutil /i command on the DLL

Hope this helps :)

Jonas Granstrand
(By Jonas Granstrand, 11/4/2010 3:05:14 PM)

Hi
Ran in to a problem, i have followed all the above steps to install CMS 6 on VS2010, at first everything worked just fine but today i got a problem.

I was going to add a epi GUI plugin in for the site i'm developing and when i do i get an error from vs2010 saying: "could not load the file or assembly 'episerver.design version=6.0.530.0..., or one of it's dependencies. The located assemblys manifest definition does not match the assembly reference".

To add a plugin was one of the first things i checked when i completed the integration because i knew i was going to use it later. At that time it worked fine, what could have happened, any suggestions?

/jonas

Andreas Ek
(By Andreas Ek, 12/4/2010 3:58:28 PM)

Thanks! Works great with the new EPiServer Integration for version 6.

Suren Azatyan
(By Suren Azatyan, 5/2/2011 6:52:45 PM)

Works for me,thanks!

David Fhager
(By David Fhager, 5/25/2011 10:18:48 PM)

Has anyone got this to work with R2 (6.1.379)?
I extracted the dll:s and the integration files from the latest EPiServerVsIntegration.msi and did all as above but I get "Value can not be null. Paramater name: path1" when trying to create project.

(Or is there someting offical soon on VS2010 or should i use the 6.0.530 files also for R2?)
The old VS feels so... 2008 ;-)

Sidharth Naidu
(By Sidharth Naidu, 6/16/2011 6:42:25 PM)

i think incorrect version of the project templates are being shipped in the zip files mentioned in the blog post if you extract the files out of the vsintegration msi everything just works fine.

Danny Walker
(By Danny Walker, 12/12/2011 6:49:07 PM)

Hi,

After reading this thread I wonder if anyone can help...

I have extracted the files from the msi, and registered bith EPiServer.Design.dll and EPiServer.VSIntegration.dll into the GAC, but still the EPiServer templates are not appearing in my copy of VS2010.

Can anyone help or advise? (further info available on request :) )

From memory, will a reboot be needed after adding to the GAC for the files to be recognised?

Jonathan Roberts
(By Jonathan Roberts, 7/27/2012 4:56:46 PM)

I am running EpiServer 6 R2 and I get the same original error 'Value cannot be null. Parameter name: path1' when I try to create an EpiServer Project using Visual Studio 2010. Is there any update to fixing this issue? I didnt want to run the downlaodable components as it is now July 2012 and I would have presumed there would be a fix already for this.
Many thanks
Jon

Please login to comment.