Views: 5107
Number of votes: 1
Average rating:

Are your blog comments on EPiServer World disappearing?

A couple of times recently I have commented on a blog post here on EPiServer World. A little later when I checked to see if there had been any other comments added, my comment had completely disappeared!

At first I though I was going totally crazy and added my comment again only to refresh the page again and see both my original and duplicate comment!

It turns out that EPiServer World is a load balanced site and unfortunately the load balancing cache invalidation for the Community functionality has a bug which means it doesn’t always work. So you add a comment on one server but then later another server answers which has the old comment list cached.

I’m told this will be fixed in the next few days (not a guarantee) when EPiServer World is upgraded to Community 4.

Nov 03, 2010

David.Knipe
(By David.Knipe, 11/3/2010 12:28:30 PM)

I noticed this behaviour and guessed it was something to do with load balancing or that I was going mad!

I also noticed the views count can be inconsistent so wonder if this has been fixed too?

smithsson68
(By smithsson68, 11/3/2010 12:49:46 PM)

@David

If the view count is based on the Community Visit functionality then I presume that will also be effected by the same bug and fixed by the upgrade to 4.

eric.pettersson
(By eric.pettersson, 11/3/2010 7:47:39 PM)

The viewsystem on world is based on Community 3.2 hopefully the upgrade will fix this issues as well :)

Jeff.Wallace
(By Jeff.Wallace, 11/3/2010 11:25:33 PM)

Yes, I noticed this as well. I am already crazy so I was certain that i wasn't "going" crazy. ;)

Please login to comment.