Views: 8847
Number of votes: 4
Average rating:

EPiServer 7: There is already an open DataReader associated with this Command which must be closed first.

I ran into the following error on an EPiServer 7 Preview site today:

There is already an open DataReader associated with this Command which must be closed first.”

The problem is that EPiServer 7 requires that the MultipleActiveResultSets is set to true in the connection string.

 

ConnectionStrings.config:

<connectionStrings>
  <clear />
  <add name="EPiServerDB" 
       connectionString="Data Source=(local)\SQLEXPRESS;
         Initial Catalog=epi;
         Integrated Security=False;
         User ID=user;
         Password=pwd;
         MultipleActiveResultSets=True" 
       providerName="System.Data.SqlClient" />
</connectionStrings>

 

 

image

Jul 19, 2012

eric.pettersson
(By eric.pettersson, 6/5/2013 6:17:06 PM)

Awsome. Strange but this did not occur when I had the db localy on my machine but on a shared server. Still same problem with episerver cms 7 the released version.

eric.pettersson
(By eric.pettersson, 6/5/2013 6:17:08 PM)

deleted post

episerver
(By episerver, 6/10/2014 1:17:55 AM)

Thanks, solved my problem :)

Please login to comment.