Error when saving page



After upgrading a customer site to R2 we started to recieve plain white pages in editmode with the message {"saved":false,"pageLink":278_661"} when hitting the save and publish button.

Any ideas?

#50338 Apr 28, 2011 8:32
  • Member since: 2003

    Have you tried enabling logging to see if you can get more information about what happens? Do you have any custom event handling on the publish event?

    #50340 Apr 28, 2011 9:46


    I have enabled the logging now. I hope it can point me in the right direction.  You are right about the event handling. There is a validation event in the global.asax on the publish event.


    #50347 Apr 28, 2011 13:20
  • Member since: 2003

    Seems like this is related to the auto save functionality in R2 (ref twitter). I'll try to get more info on the subject.

    #50661 May 09, 2011 10:41
  • Member since: 2008

    I am getting the same error message.  I am not sure if it is an error message but when i create a page, it sometimes shows me this message.  {"Saved:false","pageLink":200_203"}, or whatever the pageid is.  If i refresh the page, alll the changes are there but i do get this quite often.

    #51062 May 23, 2011 21:15
  • Member since: 2003

    Could you try turning off the auto save functionality, setting the autoSaveInterval property to 0:0:0?


    #51074 May 24, 2011 9:00
  • Member since: 2008

    Hey Mari,

    That seemed to do the trick.  I appreciate your help in this matter. 

    #51112 May 24, 2011 15:51
  • Member since: 2005

    Turning one of the best new features off is a bad solution I'm sure you all agree... Is this a bug that has been filed? We have it too on one of our upgraded sites. It's got Relate+ so I'm sure it has a saved/published event even though I don't have the code infront of me now.

    #53134 Aug 29, 2011 23:13
  • Member since: 2005


    Yes, this has been verified as a bug with the auto save feature. It's is registered in our bug system as issue #70380.


    Per Gunsarfs

    EPiServer Development Team

    #53154 Aug 30, 2011 9:16
  • Member since: 2008

    I seem to have this same problem now, with the small difference that my customer is asked to download "EditPanel.aspx". When downloaded the file content is "{"saved":false,"pageLink":"162_1115"}" how ever, so I figure that their browser is set to download that page's mimetype, what ever that may be.

    Is there any solution for this yet?

    #55899 Dec 22, 2011 10:28
  • Member since: 2007

    This bug has now been fixed. You can request a hotfix from our support department quoting bug number 70380.

    In the meantime you can turn off auto save by setting the autoSaveInterval property to 0:0:0 in episerver.config


    #55959 Dec 22, 2011 14:45
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply