Problems with Microsoft Office Add-In

Member since: 2006
 

I am having a problem with the Microsoft Office Add-In when publishing for Word. I have installed the Add in from the Microsoft Add-In tab in edit mode, set the access rights for my user, and enabled the location path="UI/OfficeIntegration" in web.config.

I get an converting error, can not convert file, while converting to EPiServer CMS Format. The page is created in EPiServer, but the page is not published. The PageName and MainIntro property gets their value, but the MainBody does not. I have enabled logging, but nothing interesting is shown there.

This works fine for other sites on the same webserver. The webserver runs Windows server 2003. I run Vista and Office 2007 on the client side.

Anybody got a clue how I can solve this?

Br, Tore

#26869 Jan 05, 2009 14:50
  • Member since: 2006
     
    Anyone got a clue how to solve this?
    #26899 Jan 07, 2009 15:05
  •  
    Not clue really, but I just learned there should be a log on the client machine located at %USERPROFILE%\AppData\Local\EPiServer\Log.txt. Perhaps it can shed some light.
    #26914 Jan 08, 2009 9:21
  • Member since: 2006
     

    Hi Cristian.

    Thanks for your tip. This i printed in my Log file:

    2009-01-08 09:35:31,227 5080 EPiServer.ShellTools FileSaveDialog: Starting wizard
    2009-01-08 09:35:31,249 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:35:31,249 5080 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 09:35:31,249 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:35:31,250 5080 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 09:35:31,250 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:35:31,250 5080 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 09:35:31,250 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:35:31,250 5080 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 09:35:33,452 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:36:12,108 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:36:14,143 5080 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 09:36:14,145 5080 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 09:36:14,146 5080 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 09:36:14,146 5080 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 09:36:15,127 5080 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 09:36:43,795 5080 EPiServer.ShellTools Progress: Konverterer til EPiServer CMS-format
    2009-01-08 09:36:44,485 5080 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 09:36:44,601 5080 EPiServer.ShellTools FileProcessor: Creating convert module
    2009-01-08 09:36:44,602 5080 EPiServer.ShellTools DataManager: Creating module base on URL: {script:http://mysite.no/UI/OfficeIntegration/Components/EPiServer.Word.wsc}
    2009-01-08 09:36:44,648 5080 EPiServer.ShellTools DataManager: Failed creating module based on URL {script:http://mysite.no/UI/OfficeIntegration/Components/EPiServer.Word.wsc} [0x800C0006]

    Do you know what can be wrong?

    BR, Tore Gjerdrum

    #26916 Jan 08, 2009 9:50
  •  

    It seems that MS Word fails load the conversion script. The error code you get is INET_E_OBJECT_NOT_FOUND.

    Which response do you get if you try to download the script with your browser?

     

    #26918 Jan 08, 2009 10:21
  • Member since: 2006
     

    Hi Stefan.

    I get "The page cannot be found". But the UI url works for edit and admin mode. And the file exists on disk in the UI/OfficeIntegration/components folder. But in the log it says Components with a capital C. Is is case sensitive? Or maybe it can be MIME types in the IIS?

     BR, Tore

    #26919 Jan 08, 2009 10:54
  •  

    Fist of all, if the site is upgraded from CMS 5 R1 it's probably a known issue. Go to the bug list http://world.episerver.com/en/Support/Bug-List/ and search for "upgrade", the bug in question is "#14708:

       HTTP 404 error is reported when clicking the Help button after upgrade site from 5.1 SP2"

    If it's not an upgraded site I'm not sure why you can't download the file, but chances are that the fix stated in the bug report still applies. Revise the <httpHandlers> section in the <location path="UI"> section and make sure that there's a wildcard mapping to EPiServer.Web.StaticFileHandler, otherwise there's no handler that will serve the script component.

    #26921 Jan 08, 2009 11:43
  • Member since: 2006
     

    Hi Stefan.

    Just thought of the same isse my selv. When I check the web.config for an upgraded site, the Ursl are siteUrl="http://mysite.no/" uiUrl="http://mysite.no/UI/" utilUrl="http://mysite.no/Util/", but for an R2 site it are siteUrl="http://mysite.no/"
    uiUrl="~/ui/" utilUrl="~/util/". I have upgraded the site from 5.1 SP3 to 5.2, so that has to be the issue.

    Thanks for your help!

    BR, Tore Gjerdrum

    #26922 Jan 08, 2009 12:21
  • Member since: 2006
     

    Hi agian Stefan.

    I did the changes to web.config that as described in the bug, but now I get this error: can`t upload files to EPiServer CMS.

    The log file looks like this:

    2009-01-08 12:41:55,013 4584 EPiServer.ShellTools FileSaveDialog: Starting wizard
    2009-01-08 12:41:55,020 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:41:55,707 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:41:55,707 4584 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 12:41:55,707 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:41:56,229 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:41:56,229 4584 EPiServer.ShellTools ConnectionManager: No ticket could be established
    2009-01-08 12:41:57,432 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:41:59,112 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:42:01,151 4584 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 12:42:01,153 4584 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 12:42:01,154 4584 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 12:42:01,155 4584 EPiServer.ShellTools Progress: Vent litt, klargjør neste trinn i veiviseren ...
    2009-01-08 12:42:06,580 4584 EPiServer.ShellTools Progress: Konverterer til EPiServer CMS-format
    2009-01-08 12:42:07,114 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:42:07,236 4584 EPiServer.ShellTools FileProcessor: Creating convert module
    2009-01-08 12:42:07,236 4584 EPiServer.ShellTools DataManager: Creating module base on URL: {script:http://acta.epinova.no/customUI/OfficeIntegration/Components/EPiServer.Word.wsc}
    2009-01-08 12:42:07,245 4584 EPiServer.ShellTools FileProcessor: Calling convert module
    2009-01-08 12:42:07,245 4584 EPiServer.ShellTools ConvertScript: Entering Word Convertor (script file)
    2009-01-08 12:42:08,379 4584 EPiServer.ShellTools ConvertScript: Leaving Word Convertor (script file)
    2009-01-08 12:42:08,379 4584 EPiServer.ShellTools FileProcessor: Found and added file C:\Users\TORE~1.GJE\AppData\Local\Temp\Hei på deg din knall_docx\page.html
    2009-01-08 12:42:08,380 4584 EPiServer.ShellTools Progress: Laster opp filer til EPiServer CMS
    2009-01-08 12:42:08,380 4584 EPiServer.ShellTools ConnectionManager: Loading ticket
    2009-01-08 12:42:08,381 4584 EPiServer.ShellTools DataManager: Open a internet session
    2009-01-08 12:42:08,381 4584 EPiServer.ShellTools DataManager: Open a internet connection to acta.epinova.no
    2009-01-08 12:42:08,381 4584 EPiServer.ShellTools DataManager: Opening request to upload file page.html
    2009-01-08 12:42:08,381 4584 EPiServer.ShellTools DataManager: Send Request
    2009-01-08 12:42:08,388 4584 EPiServer.ShellTools DataManager: Upload to server returned status code: 302 

    Any clue what I have to do now?

    BR, Tore Gjerdrum

    #26923 Jan 08, 2009 12:46
  •  

    Getting a 302 response indicates a redirect. My guess is that you for some reason are getting redirected to the login page when trying to upload the document content.

    I assume you've changed web.config according to the section "Enabling Office Integration in web.config" in the Office tech note http://world.episerver.com/en/Documentation/Items/Tech-Notes/EPiServer-CMS-5/EPiServer-CMS-5-R2/Microsoft-Office-Integration/ 

    Can you check with Fiddler [http://www.fiddlertool.com/] where the redirect points to?

     

    #26925 Jan 08, 2009 14:38
  • Member since: 2006
     

    Hi Stefan.

    I have enabled officeintegration in web.config.

    The redirect point to http://mysite.no/UI/OfficeIntegration/HandleUpload.aspx?id=1001_4049&index=0&islastbits=1&filename=page.html.The EPiServerLog does not log anything interessting.

    BR, Tore Gjerdrum

    #26926 Jan 08, 2009 15:01
First   1 2   Last 
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply