Globalisation question: Create a new page in none-english language first

 

Dear Episerver World,
First of all - I've browsed the documentation, I've searched the forum and Google but I am not sure if it is a problem or feature.

I have a Swedish site, which will also an English part (Swedish is main language) using /sv/ and /en/ urls. 

I've enabled English and Swedish in the administration area. My globalisation culture is:

    <globalization culture="sv-SE" uiCulture="sv" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Resources.XmlResourceProviderFactory, EPiServer" />

However, when I log in to the administration area english is always the main language. If I choose to view the swedish site tree, and click Create new page, that page is always English by default. Only after I've created the main page (in english) can I create a swedish alternative. 

Is it possible to get so that new pages are created in swedish automatically, not english? Or am I just beeing paranoid and this is a none-issue?

Regards,
Niklas

#26848 Dec 31, 2008 10:35
  • Member since: 2004
     

    Niklas,

    I think that English is used in Admin mode, because it has been set as the personal language for the user on the site. Check this by going to My Settings and the Display Options drop-down box. Set the personal language to Swedish (or system language in your case) to show Admin mode in Swedish.

    When you choose the Swedish site tree and create a page, is it the interface language that is in English or is the flag in the top right of the edit panel in English too?

    Best regards,
    Helen

    #26901 Jan 07, 2009 15:30
  •  
    The admin system is in Swedish, and I've taken the extra step and setting Display Options to Swedish. When I then choose the Swedish site tree ad create a page, it is created in english by default, and the site-tre is refreshed and the new page is shown in italic (Page is missing in the current language)

    So it would appear as if every new page is created in English, even though I am in the Swedish site tree and swedish is my main language.
    #26902 Jan 07, 2009 16:18
  • Member since: 2006
     

    In addition to activating languages (English/Swedish) in Admin Mode under Config/Manage Languages, you also need to set Available languages in Edit Mode. This is done to make it possible for Editors to create pages in a specific language on the Web site. It might be that this has not been set or has been changed, and therefore it is not possible to create pages in Swedish for your Web site or a certain branch of the Web site.

    Setting Available Languages is done in Edit Mode. In the toolbar, click on the Language Settings button, and change the available languages so that it is possible to create pages in both Swedish and in English.

    Also check that this property is set throughout the Web site (inherited from the start page), if you want it to be possible to create pages in Swedish everywhere.

    Hope this helps.

    Regards, Andrea

    #26917 Jan 08, 2009 10:07