System Requirements for Relate+ 2.0

Product version:

EPiServer Relate+ 2.0

Document version:

1.0

Document last saved:

{DynamicContent:PagePropertyPlugin}

Introduction

The Relate+ package contains EPiServer Community, EPiServer Mail, and the Relate+ Templates, for integration with EPiServer CMS 6. This document provides the minimum system requirements for Relate+ 2.0.

SERVER REQUIREMENTS

Operating system

Any of the following is required:

  • Microsoft Windows Server 2003 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2

Web server

Any of the following must be installed as part of the Windows Server installation:

  • Microsoft Internet Information Services (IIS) 6
  • Microsoft Internet Information Services (IIS) 7.0
  • Microsoft Internet Information Services (IIS) 7.5

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP2 32/64 bit
  • Microsoft SQL Server 2008 SP1 32/64 bit
  • Microsoft SQL Server 2008 R2 32/64 bit

Other requirements

Any of the following is required:

  • Microsoft .NET Framework 3.5 SP1
 

CLIENT REQUIREMENTS FOR EDITING

Operating system

Any of the following is required:

  • Microsoft Windows XP SP3
  • Microsoft Windows Vista SP2
  • Microsoft Windows 7
  • Mac OSX 10.5 or later

Browser for editing

Any of the following is required:

  • Microsoft Internet Explorer 7.0
  • Microsoft Internet Explorer 8.0
  • Firefox 3.5, 3.6 *
 

CLIENT REQUIREMENTS FOR BROWSING

Browser for viewing

All major browsers are supported, including:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Netscape
  • Google Chrome, Opera, Safari, Netscape

NOTE Browsers supported for viewing are entirely dependent on the construction of the EPiServer CMS templates.

 
 

DEVELOPMENT AND DEMONSTRATION ENVIRONMENT

Operating system

Any of the following is required:

  • Microsoft Windows XP SP3 32 bit
  • Microsoft Windows Vista SP2 32/64 bit
  • Microsoft Windows 7 32/64 bit
  • Microsoft Windows Server 2003 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2

Development tool

  • Microsoft Visual Studio 2008 SP1
  • Visual Web Developer 2008 Express Edition SP1

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP2
  • Microsoft SQL Server 2005 SP2 Express
  • Microsoft SQL Server 2008 SP1
  • Microsoft SQL Server 2008 SP1 Express
* The EPiServer Visual Studio integration SDK installation requires Microsoft SQL Server Express.

   

ACCESSIBILITY

WAI (Web Accessibility Initiative) standards

NOTE that the Relate+ Templates are not adapted to WAI standards.