Views: 8168
Number of votes: 1
Average rating:

EPiServer 7 – Patch 4

Today we are delivering patch 4 that addresses some issues found in EPiServer 7. This patch is cumulative meaning that it includes the changes present in Patch 1,  Patch 2 and Patch 3. Visit the installations instructions for details how to apply the patch.

Fixes that have been added

90086 "Incorrect link" when view page with same name in second language Falcon\CMS\Edit UI
99523 Site throws a NullReferenceException on start up occassionally Falcon\Framework\DDS
90887 Display "{PagePropertyPlugin} " for dynamic page property Falcon\CMS\Core\Dynamic Content
99715 MVC: Url.Action to an action to a controller that differs from main request controller will not be rewritten to an "Episerver URL" Falcon\CMS\Core\MVC
99866 Large amount of database calls to netPageDefinitionGet may occur under certain scenarios Falcon\CMS\Core\Data Access
99863 Page shortcut: Simple address doesn't work together with shortcut Falcon\CMS\Core\Routing
100263 Editing block without preview template causes crash that is visible before forms view is loaded Falcon\CMS\Legacy UI
100763 MVC: Patch 4 requires Session State in PropertyFor Falcon\CMS\Core\MVC
100551 Cannot re-edit relative links that end in '/ Falcon\CMS
100963 Second content area will not be rendered when having a blocks or pages in the first on an MVC site. Falcon\CMS\Core\MVC
99665 PageRouteHelper is hard to unit test for partners Falcon\CMS\Core
99373 [Patch 3 Installation]Error when sending email site that has been updated from Patch 2 Falcon\Mail
99615 Shadowing module providers causes module initialization to randomly miss module assembly association Falcon\Framework\Configuration
104979 XForm can't handle multil language in MVC Falcon\CMS\Core\XForms
104835 The ObjectSerializers are shared between threads but are not thread safe Falcon\Framework
101355 A controller named HomeController won't be instantiated by the controller factory Falcon\CMS\Core\Routing
99614 Validation of URL segment is wrong Falcon\CMS\Core\Routing
100118 EPiServer Find not finding fallback results for every language. Falcon\Find\CMS Integration
105402 Duplicate key error (PublishedInLanguage) when indexing a page with the same mapping for both replacement and fallback language Falcon\Find\CMS Integration
99131 Episerver 7 MVC - Multiple Xfrom on same page Falcon\CMS\Core\MVC
100582 Updating a document in DocumentArchive deletes the file Falcon\Community\API
99075 [Find] ReflectionTypeLoadException after upgrading Find module Falcon\Find

Installing the patch

The patch is available as a set of packages on Nuget feed on nuget.episerver.com. Refer to the installation instructions for information on how to install the patches to your sites.

Related documents



Hi everybody , ( I feel it is biggest issue in episerver mvc template why it was not taken care and why no body even respond to this question)

did any one of u face the below issue with alloy mvc site or any custom Episerver cms site developed based on mvc template ?
if u restrict a block on a page then the page it self is not visible. for example i restricted "news list" block on alloy-track page by deleting everyone group from it. but note that "Alloy-track page is having access to everybody. so expected functionality is user should see "Alloy-track" page but news list block should not visible. (this is default behaviour in Alloy - webforms ).
But actual behaviour is it is redirecting to login page !!!
note : I am facing same problem in my custom Episerver mvc site. can any body help me how to resolve this issue. thanks in advance

Hi nani,

Thanks for sharing this. I have reported this as a bug (#106256) and we hope to have a fix available in the next patch release.

Sorry for any inconvenience this may have caused you.

Hi code monkey. I checked the crm but your user isnt connected to the support so guess you have used another email to register the case. Found one case that i believe is yours and have dropped you an email (gmail) to request more info to confirm its the correct one.

i just updated via nuget to version 7.0.859.24 of Episerver.Framework and Episerver.CMS,Core, and now i get this error in event viewer when i try to access my website:

Could not load file or assembly 'EPiServer.Shell, Version=7.0.859.16, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

so something still depends on the old version of Episerver.shell.

i have earlier updated via addons in episerver and my packages.config file in modules folder look like this:






could it be some of those dll that relay on the old version of episerver.shell?

@larswo, This should be handled by version redirect. When installing any episerver nuget package we configure the application to use the newly installed version of the assembly. However, we have had cases when this have failed and this might be one of them. Can you look in the web.config file and make sure that there is a assembly binding configuration for episerver.shell (and all other episerver assemblies) the redirects any references to use the patch 4 version of the assemblies (version number ends with .24).

While trying to install this patch following the installation instructions i notice that the version of the EPiServer.CMS.Core and EPiServer.Framework which Nuget is trying to update is 7.5.394.2(which i believe requires you to upgrade site to CMS 7.5 right?) while the patch 4 assembly version should be 7.0.586.24. I have tried to use the Nuget Powershell Addon and added the version number i want to install, but this method allways fails saying that i have no compatible project(s) found. Which doesn't make sense. The customer only wants to install patch 4 without having to upgrade to CMS 7.5. Any pointers on what to do?

With the following command, you should be able to update to Patch 4 of the CMS.

Update-Package EPiServer.CMS.Core -Version 7.0.586.24

I get this error trying to install with PMC:
Update-Package : 'EPiServer.CMS.Core' was not installed in any project. Update failed.
At line:1 char:15
+ Update-Package <><><>< EPiServer.CMS.Core -Version 7.0.586.24
+ CategoryInfo : NotSpecified: (:) [Update-Package], PackageNotInstalledException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.UpdatePackageCommand

Ive also tried browsing http://nuget.episerver.com/ hoping to find the package as a standalone download so i can install the dll's manually but the links on the page doesn't send you to the correct package and the Project site links all send you to a "Sorry, but the page could not be found" - page.

"'EPiServer.CMS.Core' was not installed in any project." indicates that you don't have a previous version of the nuget packages present in the project. In that case you should use install-package instead of update-package with the exact same parameters.

The links to EPiServer.CMS.Core on the page linked below all lead to the info page for the CMS 6 patch. Not very useful :)
http://nuget.episerver.com/en/?search=&sort=MostDownloads&page=1&pageSize=10

Please login to comment.