Where did the EP* settings go?

Magnus Rahl
Member since: 2008

In 4.62 there were many settings in web.config prefixed with either EPn EPs or EPf, like registration email settings, smtp server settings etc. Are there any corresponding standard settings in CMS 5 or is this left to the developer?

#28002 Feb 17, 2009 10:05
  • Tore Gjerdrum
    Member since: 2006

    Hi Magnus.

    have you tried the EPiServer.Configuration namespace?

    Br, Tore

    #28003 Feb 17, 2009 10:12
  • pappabj0rn
    Member since: 2007
    Some of the settings are now standard asp.net settings and those that are episerver specific can now be found in the siteSettings element.
    #28012 Feb 17, 2009 13:29
  • Magnus Rahl
    Member since: 2008

    I suspected many of the settings hade become asp.net standard when I couln't find corresponding values in Configuration.Settings.

    Perhaps I should be more specific. What I'm looking for is the possibility to configure the SmtpClient to use something other than localhost. I can do this at run time, possibly utilizing an appSettings value. But is there a more standard way (one used internally in aspnet or episerver), like EPsSmtpServer etc. used to be?

    Further, are the EPfEnableFreeRegistring, EPsRegistry* and EPsActivation* replaced by values related to membership providers now, or are they just obsolete?

    #28024 Feb 17, 2009 15:37
  • Eric
    Member since: 2007

    Den här kan du leta efter för smtp... Men det skiljer sig dessutom lite mellan iis6 och 7 med så det får man kolla upp beroende på site.. detta är från en iis7.

    <!-- SMTP Settings for ASP.NET 2.0 Mail classes. -->
                <!--<smtp deliveryMethod="PickupDirectoryFromIis" />-->
                <!-- Common usage is to use other network existing mail server other than
                     IIS Virtual SMTP Server.
                     In such cases use the commented settings below with your server
                     location and authentication credentials.
                <smtp from="yourmailadress" deliveryMethod="Network">
                    <network host="yourhost" port="25" defaultCredentials="false" />



    #28032 Edited, Feb 17, 2009 23:24
  • Magnus Rahl
    Member since: 2008
    #28039 Feb 18, 2009 7:51