"Loading Editor..."

Hi, A lot of our editors are having problems with the editing windows getting stuck displaying "Loading editor..." instead of the toolbar and text input. This seems to happen randomly on different templates and in different user scenarios. It has even happened with pages with no content in them, any ideas? Thanks in advance
#11387 Mar 25, 2008 18:32
  • Henrik Staberg
    Member since: 2004
    This might be a known bug caused by hr-tags ("
    ") in the text. Try to get previus versions of the page and then remove the hr-tag in the editor, or create code to remove the hr-tag of the current version.
    #11773 Mar 25, 2008 18:33
  • Henrik Staberg
    Member since: 2004
    I forgott to write that the hr-bug generates a JavaScript error when loading the editor. Is there any error in the statusbar of explorer or any popups?
    #11774 Mar 25, 2008 18:33
    Vi har också haft det problemet och misstänkt att det har samband med
    . Är det alltså en känd bugg i programmet?
    #11775 Mar 25, 2008 18:33
  • Per Hemmingson
    Member since: 2006
    Hi. Yes we have recieved different reports of problem with
    tags in the editor but have not been able to reproduce the problem in development. issue: 0045045:
    tags may cause scripterrors when the editor is loading Note, If you are using Internet explorer 7 you should download the ie7 fix from http://www.episerver.com/en/EPiServer_Knowledge_Center/News--Information/News-Knowledge-Center/Updated-templates-and-style-sheets-available-at-EPiServercom/ It solves: Tables in the editor. Right click menu in View mode. Setting focus in an editor by clicking it. Solved certain issues with Internet Explorer and doctype declarations. Changes made to MasterPage.master to make the left hand menu appear correctly. Fixed rendering of left menu. Added an img.childindicator class and div.menutext to correctly render the small arrow image and the menutext. Changed rendering of listitems in WorkroomList.ascx.
    #11776 Mar 25, 2008 18:33
  • Per Hemmingson
    Member since: 2006
    Hi again. Another thing, the problem can be a javascript error so check that first and also check that the browser can run javascript. If the site has recently been upgraded to newer version of episerver then some old javascript files can be loaded from the cache. So clear the cache too. Regards Per
    #11777 Mar 25, 2008 18:33
    Felet kan enkelt framkallas på detta sätt: 1. Skapa en vanlig webbsida 2. Infoga Horisonell linje 3. Tryck 4. Spara och publicera. Nästa gång du försöker redigera sidan uppstår problemet.
    #11778 Mar 25, 2008 18:33
  • Rizo
    Member since: 2007

    I find this VERY annoying. Every time I find an answer in the forum, it ALWAYS points into a dead link.



    doesnt work at all and cant even be searched upon.Frustrating and annoying.

    #28974 Apr 01, 2009 8:57
  • carina.dorst
    Member since: 2003

    Try this one cause it worked for me.

    In web.config find tag <add key="EPfHtmlEditor" and set the value to true or false. This Depends on witch editor you use, Dhtml (True) or ActiveX component (False)



    #29707 May 09, 2009 1:27