Join our community!

Get everything you need to start developing EPiServer solutions.

Security vulnerability - Elevation of privilege

Jens Nygård
Tuesday, 10 January 2012
Security  CMS5  CMS6 

  • Number of votes: 2
  • Views: 4894
  • Average rating:

A security vulnerability has been detected which allows elevation of privilege for a user that has access to Edit mode in EPiServer CMS 5 and CMS 6. In practice this means that someone with editorial privileges could take ownership of the “WebAdmins” account.

Websites based on EPiServer CMS 5 and 6 using Forms Authentication with a Membership provider that supports updating are affected by this security vulnerability. Websites using Windows Authentication or Forms Authentication with Windows Membership provider are not affected.

We recommend our partners to contact EPiServer Developer Support to obtain a hotfix for the CMS specific security concerns.

The above shares some characteristics with the vulnerability previously reported by Microsoft, but should not be mistaken as the same. For more information see Microsoft Security Bulletin MS11-100

Comments

About the blogger

Jens Nygård
EPiServer AB
Citizen

Director of Services

Syndication and Sharing