Last updated: Apr 26 2015

EPiServer - update 63

This update includes two new features for EPiServer CMS UI; Allowed/Restricted types filtering for ContentSelector dialog and Improved search results in Blocks widget and Media widget. It also includes bug fixes for EPiServer CMS UI and Commerce.

EPiServer CMS Core is releasing a pre-release of EPiServer Logging Log4Net, which includes support for Log4Net v2. It is an unsupported feature for CMS at the moment, implementation for Commerce will be released together with Commerce 9.

The update is applicable to EPiServer projects version 7.5 and higher, and contains finalized work items included in the latest iteration. The update is available for installation from the EPiServer NuGet feed. Continuous release updates are cumulative, meaning that the latest always includes previous updates. All platform updates are supported and we strongly recommend that you keep ongoing projects up to date.

Latest changes

Click a package in the list below to see work item details. Refer to Release notes for an overview of latest changes. See Installing EPiServer updates for information on how to install EPiServer updates using NuGet.

Updated packages  

EPiServer CMS Core

Features
  • Pre-release of feature #119813: Upgrade logging implementation to use log4net 2.0.3

EPiServer CMS UI

Features

  • #122884 Allowed/Restricted types filtering for ContentSelector dialog
  • #123208 Improved search results in Blocks widget and Media widget

EPiServer Commerce

Issues with NuGet updates

In some specific upgrading scenarios you might experience problems with the dependency chains, due to issues in NuGet. This mostly affects Commerce and Find, but might also occur when updating CMS. The workaround is usually to update the packages one-by-one. Refer to Issues with NuGet package updates for more information.

Important notifications

Note the following version-specific information:

  • From update 6, EPiServer UI components (CMS and Commerce after version 7.6.0) have been converted to NuGet packages. Location of packages have changed and might affect the installation if you are going from the first to the latest update, refer to Changes to package locations.
  • From update 35, .NET Framework 4.5 is required, see System requirements and Upgrading to .NET Framework 4.5.
  • Update 36 included breaking changes for Commerce, refer to Breaking changes Commerce 8.
  • From update 40, workflows are disabled by default to simplify Azure deployment. Refer to Activating workflows for information on how to enable them.
  • Update 55 included breaking changes for CMS and Find

Related information