Unexplainable error occuring

Vote:
 

Hi all,

We're trying to get to the bottom of some performance issues we are experiencing with Relate. Whilst it may be completely unrelated - the EPiServer logs list the same exception hundreds of times, which we would like to get to the bottom of, if nothing more than to exclude it from our investigation. The error is:

2013-04-15 18:01:48,206 ERROR [35] EPiServer.Common.TaskQueue.Timer_Elapsed - EPiServer Common: An exception was thrown when task was invoked by TaskQueue: 'Episerver.Community.Search.SearchModule.taskQueue'. The message was: Parameter has no page set
Parameter name: pageLink. Stacktrace was: at EPiServer.DataFactory.GetPage(PageReference pageLink, ILanguageSelector selector)
at EPiServer.Templates.RelatePlus.Pages.Base.PageBase.get_MyPage()
at EPiServer.Templates.RelatePlus.ExtensionMethods.GetMyPageUri(IUser user)
at EPiServer.Templates.RelatePlus.CommunityModules.UriProvider.GetUri(Object obj)
at EPiServer.Community.Search.SearchHandler.AddUriToIndexItem(IEntity entity, IndexRequestItem item)
at EPiServer.Community.Search.SearchHandler.ConvertEntityToIndexItem(IEntity entity, IndexRequestItem item)
at EPiServer.Community.Search.SearchHandler.UpdateIndex(Int32 entityId, IEntity entity, IndexAction action)
at EPiServer.Common.TaskQueue.Timer_Elapsed(Object sender, ElapsedEventArgs e)

We're not really seeing from this log entry why this could be occuring considering it is within managed code. Any thoughts anyone?

Thanks

Al

#70274
Apr 16, 2013 13:38
Vote:
 

One of the options is that you could check "My Page" property on Start Page -> does it points to valid CMS page?

#70753
Apr 29, 2013 15:23
Vote:
 

I have the same problem (EPiServer.Common.TaskQueue.Timer_Elapsed).

Have you found out why or what it is?

On my site there is sporadic performance problems, and I got the same error in the episerver log

#75124
Sep 18, 2013 12:37
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.