Community Gadgets missing

Vote:
 

Hey All,

 

i have the relate+ 2.0 installed, including commuity framework, but on the start page, i only see the normale gadgets, but not the community gadgets.. I need to the abuse report gadget.. I found some similar posts about the roles added to the episerverframework.config virtualroles for CmsAdmins.. everything is correct...


Also can anyone point me to some sample code for how to implement a report abuse button (on a forum) so it gets registrated in the abuse report...

 

thanks in advance

 

#61027
Sep 05, 2012 10:56
Vote:
 

User should be in the one of the following roles to be able to access Community gadgets:

  • Administrators
  • CommunityAdmins
  • CommunityModerators
#61042
Sep 05, 2012 13:18
Vote:
 

Ahh thanks alot .. i found that... and that part works... i see the gadgets


Do you know some sample code for the report abuse button, so it is registrated in the abuse gadget???

 

 

#61046
Edited, Sep 05, 2012 14:34
Vote:
 

I don't have any code to enable abuse reports in forums, but you could look at other places in Relate templates where abuse reporting is implemented. For example, following controls: ~/Templates/RelatePlus/UserControls/ImageGalleryUserControls/ViewImage.ascx and  ~/Templates/RelatePlus/UserControls/ReportEntity.ascx

#61047
Sep 05, 2012 14:56
Vote:
 

Those were the pointers i needed... thanks alot... I didnt know there were so many template... episerver noob here...  :-) thanks Dmytro...

#61050
Sep 05, 2012 15:03
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.