EPiServer Full Text Search Service 404 error

Vote:
 

When navigating to my ReIndexRelatePlus2.aspx page to reindex my search I get the following error in the log files:

Update batch could not be sent to service uri 'http://bayercareupgrade/IndexingService/IndexingService.svc/update/?accesskey=local'. Message: 'The remote server returned an error: (404) Not Found.   at System.Net.HttpWebRequest.GetResponse()
at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)
at EPiServer.Search.RequestHandler.SendRequest(SyndicationFeed feed, String namedIndexingService, Collection`1 ids)'
 
If I navigate to here: http://mysite/IndexingService/IndexingService.svc I successfully get to the service with 'endpoint not found'
But if I navigate here: http://mysite/IndexingService/IndexingService.svc/update I get a 404. 
I've checked this against another dev machine and in the second instance I should successfully get to the service with 'method not allowed'

 

#50652
May 09, 2011 4:47
Vote:
 
Sorry about the tiny writing let me try that last part again If I navigate to here: http://mysite/IndexingService/IndexingService.svc I successfully get to the service with 'endpoint not found' But if I navigate here: http://mysite/IndexingService/IndexingService.svc/update I get a 404. I've checked this against another dev machine and in the second instance I should successfully get to the service with 'method not allowed'
#50653
May 09, 2011 4:52
Vote:
 

Is the WCF framework installed on the IIS? You can install it by running %windir%\Microsoft.NET\Framework\v3.0\"Windows Communication Foundation"\ServiceModelReg.exe –i

#50654
May 09, 2011 7:24
Vote:
 

Thanks that was the issue. I can now navigate directly to svc/update without a 404. But sadly the search is still not working. I am getting this error in the log now: 

"For security reasons DTD is prohibited in this XML document" 

Full details below 

2011-05-09 06:45:34,285|No access key found. Access denied.
2011-05-09 06:45:34,710|Could not get search results for uri 'http://bayercareupgrade/IndexingService/IndexingService.svc/search/?q=((EPISERVER_SEARCH_DEFAULT%3a(lorem))+AND+((EPISERVER_SEARCH_TYPE%3a(EPiServer.Community.Blog.Entry%2c+EPiServer.Community.Blog))+OR+(EPISERVER_SEARCH_TYPE%3a(EPiServer.Community.Blog.EntryComment%2c+EPiServer.Community.Blog))))+AND+(EPISERVER_SEARCH_ACL%3a(U%3a7c643812-e294-4f26-b534-73b3daa98c9b)+OR+EPISERVER_SEARCH_ACL%3a(G%3aAdministrators)+OR+EPISERVER_SEARCH_ACL%3a(G%3aAllCoursesGroup)+OR+EPISERVER_SEARCH_ACL%3a(G%3aCommunityAdmins)+OR+EPISERVER_SEARCH_ACL%3a(G%3aCommunityMembers)+OR+EPISERVER_SEARCH_ACL%3a(G%3aCommunityModerators)+OR+EPISERVER_SEARCH_ACL%3a(G%3aGroup+for+Club+with+Id%3a+1)+OR+EPISERVER_SEARCH_ACL%3a(G%3aGroup+for+Club+with+Id%3a+2)+OR+EPISERVER_SEARCH_ACL%3a(G%3aSpinifexAdmins)+OR+EPISERVER_SEARCH_ACL%3a(U%3aSpinifexAdmin)+OR+EPISERVER_SEARCH_ACL%3a(G%3aEveryone))+AND+(EPISERVER_SEARCH_ITEMSTATUS%3a(1))&namedindexes=&offset=0&limit=10&format=xml&accesskey='. Message: For security reasons DTD is prohibited in this XML document. To enable DTD processing set the ProhibitDtd property on XmlReaderSettings to false and pass the settings into XmlReader.Create method. at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res, String arg)
at System.Xml.XmlTextReaderImpl.ParseDoctypeDecl()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlReader.MoveToContent()
at System.Xml.XmlReader.IsStartElement(String localname, String ns)
at System.ServiceModel.Syndication.Atom10FeedFormatter.CanRead(XmlReader reader)
at System.ServiceModel.Syndication.SyndicationFeed.Load[TSyndicationFeed](XmlReader reader)
at System.ServiceModel.Syndication.SyndicationFeed.Load(XmlReader reader)
at EPiServer.Search.RequestHandler.<>c__DisplayClass6.<GetSearchResults>b__4(WebResponse response)
at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action'1 responseHandler)
at EPiServer.Search.RequestHandler.GetSearchResults(String query, String namedIndexingService, Collection'1 namedIndexes, Int32 offset, Int32 limit)

#50675
May 09, 2011 23:37
Vote:
 

Found what was wrong with this one. Missing the accessKey name in the web config:

<add name="localIndexingService" baseUri="http://mysite/IndexingService/IndexingService.svc" accessKey="local" />

#50677
May 10, 2011 5:48
Vote:
 

I am getting the same issue. I have installed the WCF service and it is hitting my breakpoint with in the service but it is returning Endpoint not found. Any ideas?

#56219
Jan 12, 2012 13:47
Vote:
 

Sorry I forgot to tell that I am integrating episerver search service in CMS 6 R2. I have installed the service as a seperate module to the site but I cannot get the service working.

#56220
Jan 12, 2012 13:55
Vote:
 

I am getting the same issue as what rachel described in her first post, i have tried to install WCF with the command given although am still facing the 404 issue any idea on what else could be causing this ?

#58046
Apr 11, 2012 16:47
Vote:
 

Even i am facing the same error, can any one suggest me

#59688
Jun 21, 2012 14:10
Vote:
 

I Had this problem to, but I realized it is not an 404 error. It's an 404.15 error, meaning that the querystrging is to long

I solved it by adding the following to the generic system.webServer section of web.config.
 
 
<system.webServer>
    <security>
        <requestFiltering>
            <requestLimits maxQueryString="10000" />
        </requestFiltering>
    </security>
</system.webServer>
#62121
Oct 15, 2012 10:52
Vote:
 

Here, the following handler was missing:

<add name="svc-Integrated-4.0" path="*.svc" verb="*" type="System.ServiceModel.Activation.ServiceHttpHandlerFactory, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv4.0" />
#146995
Apr 01, 2016 22:03
Vote:
 

I solved my problem with no indexing by:

A) Creating hosts file entries on the server for the site

          127.0.0.1  thesite.local

B)  Then added this binding to the site with the port 2000

C) Then updating the relevent part of the web.config to this:

<add name="serviceName" baseUri="http://thesite.local:2000/IndexingService/IndexingService.svc"

D) Thats it.

Marshall

#175035
Feb 09, 2017 19:13
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.