Best practices for clean install of Relate+

g
g
Member since: 2005
 

What are the best practices for performing a clean install of CMS 5 and Relate+ (Community and EPiMail) for local development purposes (Vista, VS2008 and Cassini)? No demo templates and our own namespace.

My guess is this in general:
1. Community 3.2.0.191 - "Install site and SQL Server database" (with EPiServer CMS integration) on staging server
2. Install EPiMail somehow (copying from other installation)
3. Copy everything locally
4. Create empty project and add references to EPiServer assemblies and modify web.config.

Or is there an easier way to get everything cleanly installed?

#29133
Apr 08, 2009 14:44
tost
Member since: 2007
 

Hi Håkan!

Currently there is no easy way of installing Community on top of a existing CMS installation. Therefore the easiest way is to do like this:

  1. Install Relate+ with EPiServer Deployment Center
  2. Install Hotfix 1 for EPiServer Community 3.2
  3. Upgrade to CMS R2 SP1 with EPiServer Deployment Center
  4. Install EPiServer Mail
  5. Install Hotfix 1 for EPiServer Common
  6. Remove all pages and page types you don't want
  7. Remove attributes and forum rooms you don't want
  8. Remove appSettings for Relate+ from web.config
  9. Clean up solution

Seems like a lot of work, but actually it is done pretty quick. If you are several persons in the development team I advice you to use a common database and have your own site set up on each of the development machines. Personally I prefer to use the IIS, but Cassini will work just fine.

Best regards,
Tom Stenius

#29147
Apr 09, 2009 9:23
g
Member since: 2005
 

Great. I will try this approach. Maybe give feedback later on.

Thank you!

Håkan

#29149
Apr 09, 2009 11:40
g
Member since: 2005
 

Oh, and yes, we do use common databases, cassini, subversion and set upp VPP on UNC shares such as \\server\vpp\project\global\.

H

#29150
Apr 09, 2009 11:46
tost
Member since: 2007
 

Great! Good luck!

//Tom

#29151
Apr 09, 2009 12:10
steven.pap
Member since: 2007
 

As this is related to first time installs maybe you know why the following is happening?

I have not had a chance to investigate this.

When clicking on the 'Members' page a script error appears in the bottom bar of IE. not a very useful err description of "Line 2 char 1 syntax err." any clue..?

#29605
May 06, 2009 16:26
steven.pap
Member since: 2007
 

If I've installed Relate + 'EPiServer RelatePlus 1.0.0.2'. Will the 'Install Hotfix 1 for EPiServer Community 3.2' be included?

When I downloaded the install there was no hotfix listed so would assume so.

Please advise?

Steven

#29606
May 06, 2009 16:44
Petter Klang
Member since: 2008
 

Hi Steven,

As Mail is a part of the Relate+ package you will need the Hotfix. When you go to the download page for EPiServer Mail it will get listed under the Hotfix list.

#29609
May 06, 2009 18:21
steven.pap
Member since: 2007
 

Thanks for that. I have updated the site with the hotfixes..

Do you perhaps have some idea about my previous Q on the script err:

"When clicking on the 'Members' page a script error appears in the bottom bar of IE. not a very useful err description of "Line 2 char 1 syntax err." any clue..?

After some investigating my suspicion is that it's the Ajax.. part of it.. but not sure yet..

<asp:UpdatePanel /> used on the page..

#29612
May 06, 2009 18:53
steven.pap
Member since: 2007
 

I have removed the update panel to try and isolate the script error.it's within there that it happens somewhere..

#29630
May 07, 2009 11:07
steven.pap
Member since: 2007
 

Narrowed the script error down to the control:

<RelatePlus:Members ID="ucMembers" runat="server" PageSize="12" OnMembersChanged="ucMembers_OnMembersChanged" />

 

#29633
May 07, 2009 12:36
steven.pap
Member since: 2007
 

this may make sense:

XML tag name mismatch (expected meta) createCallback()("")ScriptRe...=66d72566 (line 5) Members.aspx?_TSM_HiddenField_=ctl00_RelateScriptManager_HiddenField&_TSM_CombinedScripts_=%3b%3bAjaxControlToolkit%2c+Version%3d3.0.20229.20843%2c+Culture%3dneutral%2c+PublicKeyToken%3d28f01b0e84b6d53e%3aen%3a3b7d1b28-161f-426a-ab77-b345f2c428f5%3ae2e86ef9%3a1df13a87%3a8ccd9c1b()()

#29634
May 07, 2009 12:48
steven.pap
Member since: 2007
 

have got to the bottom of this. In the relate+ package calls such as

type="text/javascript" src=http://download.skype.com/share/skypebuttons/js/skypeCheck.js

AND http://mystatus.skype.com/smallicon/

will not function correctly with strict firewall rules..

#29668
May 08, 2009 10:44
Arnold Macauley
Member since: 2005
 

Following on from the initial post is there a best practice method for deploying a relate+ website into a production environment? i.e. once I have added new attributes - at the moment I am having to manually add these to each machine that install it onto.

Many thanks in advance

#29682
May 08, 2009 14:22
tost
Member since: 2007
 

Hi Arnold,

Sorry to say that you have to add the attributes manually at the time being.

//Tom

#29757
May 12, 2009 13:36
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.