New install: Cannot login to EPiServer mail

Vote:
 

I am trying to evaluate EPiServer mail for one of our EPiServer 5 projects, but cannot login once it installed without errors.

I am running on WinXP and installed EPiMail into the same directory as a clean EPi5 demo site, and also used the same DB as EPi5.

EPi5 was successfully installed and I am currently configured to use SQL membership and role providers. The user I log in with is a member of all roles, including Everyone, Administrators, MailAdmins and MailEditors etc.

The "Mail" tab appears in the editor, but only contains a yellow envelope icon - all of the menu options I can see in the user guide are not present.

If I try and login to Netstar/Admin I get an ASP error, and if I try to access Netstar/Admin/Login.aspx I get a login box but it won't accept my user.

I've tried installing EPiMail with both RFR Provider and RFC integration provider and neither works.  If I use RFC Integration provider my membership provider changes to StarSuiteIntegrationMembershipProvider, but then I can't create users in ASP config (I get a big exception error message).

I also tried changing my web.config roleToSynchronize1="Administrators" (also WebAdmins) and logged out etc but it didn't help.

Throughout all of this, the table tblStarSuiteUser remains stubbornly empty, but another post on this forum that had much the same problem as me managed to get an admin user to appear in there, so I think that could be the key to my problem.

tblStarSuiteGroup has Administrators, MailAdmins and MailEditors in it, and tblStarSuiteGroupAdministrativeAccessRight has various permissions allocated for Administrators. I also manually edited this table to give the other two roles the same rights.

If anyone can suggest how I can login to EPiMail it would be greatly appreciated.  I feel I'm close, but that doesn't really help if I can't actually use the system!

One other thing that may or may not be a problem. If I try and build my site in VS2005 I get three errors:

Error 1 Could not load type 'EPiServer.Mail.Core.Web.LicenseRequestControls.FormControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\FormControl.ascx 1 Error 2 Could not load type 'EPiServer.Mail.Core.Web.UI.Mail.LicenseRequestControls.EPiServerControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\EPiServerControl.ascx 1 Error 3 Could not load type 'EPiServer.Mail.Core.Web.LicenseRequestControls.NetstarControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\NetstarControl.ascx 1

 
These DLLs are not present in my bin directory.
I have tried reinstalling EPiServer Mail several times, but they do not seem to get installed.  

Thanks for any help,

/\dam

#23705
Sep 13, 2008 17:59
Vote:
 

(formatting error)

The three errors above were:

Error 1 Could not load type 'EPiServer.Mail.Core.Web.LicenseRequestControls.FormControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\FormControl.ascx 1
Error 2 Could not load type 'EPiServer.Mail.Core.Web.UI.Mail.LicenseRequestControls.EPiServerControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\EPiServerControl.ascx 1
Error 3 Could not load type 'EPiServer.Mail.Core.Web.LicenseRequestControls.NetstarControl'. S:\inetpub\MyEPiServer\myUI\Mail\LicenseRequestControls\NetstarControl.ascx 1

 /\dam

#23706
Sep 13, 2008 18:01
Vote:
 

EPiServer support have replied back to me and sent some config settings that have fixed this issue:

<membership 
defaultProvider="StarSuiteIntegrationMembershipProviderSQL"
userIsOnlineTimeWindow="20">

<add name="StarSuiteIntegrationMembershipProviderSQL"
applicationName="StarSuiteApplicationSQL"
type="StarSuite.Core.Web.Authorization.IntegrationMembershipProvider, StarSuite.Core.Web.Authorization"
provider="SqlServerMembershipProvider"
roleToSynchronize1="Administrators" />
 

I'm still not sure if this is a WinXP-only issue, but assume that it is because I've since installed on Windows Server 2003 without any problems.

Anyway, hope the above helps someone,

/\dam

#24105
Sep 24, 2008 12:19
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.