Critical Upgrade fail 3.0 -> 3.1.2

Vote:
 

Hi,

I'm trying to upgrade my installation of Community to the latest version available (3.1.2) and I hva some problems with this. First; the installation documentation is obsolete and stuff I get asked for during the install is not documented and leads to a lot of confusion. Specially the RFC provider issue. Nevertheless, the entire installation fails at a "Invalid object name 'tblStarSuitePasswordProvider'"

Doing a quck lookup in the database reveals no tblStarSuitePasswordProvider table. Anybody know what this is all about?

 

M.

The installation log reads:

[544] INFO EPiServer.Install.Wizard.Data::DatabaseHelper.ExecuteNonQueryBatch+9 - Running SQL statement #37

37187 [544] ERROR EPiServer.Install.Wizard.Steps.CloserStep - Installation threw an exception.

System.Data.SqlClient.SqlException: Invalid object name 'tblStarSuitePasswordProvider'.

at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)

at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)

at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)

at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)

at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)

at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)

at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()

at EPiServer.Install.Wizard.Data.DatabaseHelper.ExecuteNonQueryBatch(StreamReader batchStream, SqlTransaction transaction, NameValueCollection substitutes)

at EPiServer.Install.Wizard.Data.DatabaseHelper.ExecuteNonQueryBatch(StreamReader batchStream, SqlTransaction transaction)

at EPiServer.Install.StarCommunity3100.Closer.ExecuteUpgrade(SqlTransaction transaction, IProgressForm progressForm)

at EPiServer.Install.StarCommunity3100.Closer.Execute(SqlTransaction transaction, IProgressForm progressForm)

at EPiServer.Install.Wizard.Steps.CloserStep.RunClosers()

312406 [544] INFO EPiServer.Install.Wizard::BaseWizard.MoveTo+8 - Setting current step to 'failure', moving in direction 'Jump'.

#23317
Sep 03, 2008 10:35
Vote:
 

Hi Marius,

Have you in any way unchecked the Required Framework Components 2.2 packade from the installation steps?

#23319
Sep 03, 2008 10:48
Vote:
 

No, every option is checked during the install. However, just checking the RFC 2.2 package and choosing "RFC provider" (no integration) resulted in a successfull update of the framework.

Starting again, with checked upgrades (Framewok, Community)RFC Provider, Upgrade option set for Action on RFC, Action of Community 3.0.3.0 to 3.1.0.0 (Create tables checked) results in same Error (Upgrading Database step of installer) at the tblStarSuitePasswordProvider table.

Listing install options before beginning installation

General:
[*] SQL Server: (local)
[*] Database: kreftforeningen
[*] IIS Web: Default Web Site (c:\inetpub\wwwroot)

Required Framework Components 2.2.0.0:
[*] Action: Upgrade
[ ] Tables and Stored Procedures
[ ] Replicate Members and Roles
[*] Default Membership and Roles Provider: RFC Provider

StarCommunityTM 3.1.0:
[*] Action: Upgrade
[*] Tables and Stored Procedures
[ ] Files
[ ] EPiServer Integration

 

#23320
Sep 03, 2008 10:59
Vote:
 
If you succeeded with installing the required framework in the first step, then try to install Community packages as a second step.
#23327
Sep 03, 2008 13:13
Vote:
 

I have tried the various options of installing each component, upgrade/install. It fails every time on the same table. Applying the installation to a new database works, but on my existing database it does not.

I'm logging on the database as 'sa' user btw

#23419
Edited, Sep 05, 2008 9:46
Vote:
 

Hi Marius,

We've identified an issue with the upgrade. Please download the updated installer from http://world.episerver.com/en/Download/Items/EPiServer-Community/EPiServer-Community-31/

/Kristoffer

#23968
Sep 19, 2008 10:55
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.