How to set up a project to work via IIS?

Vote:
 

I just started with the EpiServer. Therefore, many questions. Please help.


 I created a simple project in VS2008 with one form of Default.aspx for EpiServer.
 I put in connectionStrings.config path to the database.
 Via the VS2008 project runs without errors.
 But when I copied the project folder in C:\EPiServer\Sites\MyEPiServerSite\MySimpleProject
 Browse through and made ​​the IIS? I got the error:

 Url http://localhost:17000/MySimpleProject

 Exception details: ConfigurationErrorsException: It is an error to use a section registered as allowDefinition = 'MachineToApplication' beyond application level.
 This error can be caused by a virtual directory not being configured as an application in IIS.
 (C:\EPiServer\Sites\MyEPiServerSite\epiproperty\web.config line 183)


 How to set up my simple project to work via IIS.
 I want to run the project from the website IIS\Web Sites\MyEPiServerSite\MySimpleProject\Default.aspx

#51155
May 25, 2011 17:07
Vote:
 

Hi

The simplest way I know to start a project is to install a site with Deployment Centre and also add the public templates. After that just open PublicTemplates.csproj in VS and start programming. This way the Deployment Centre sets up a site for you the correct way. I recomend you read this guide: http://www.frederikvig.com/2009/12/introduction-create-an-episerver-site-from-scratch/

#51157
May 25, 2011 19:32
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.