EPiServer.Blog and Live Writer

Vote:
 

I'm trying to use the blog template from the demotemplates with Windows Live Writer.

I have used the tips below since it is a protected site:
http://world.episerver.com/Blogs/Mari-Jorgensen/Dates/2010/8/Live-Writer-and-Protected-Blog-Pages/

My problem is that Windows Live Wtier (LW) fails to connect to the blog when I try to "Add blogg account".

After entering the blog URL, username and password Live Writer giv me the following dialog:

Select blog type
Windows Live Writer was not able to automatically detect your blog settings.
Please select the type of blg that you are using to continue.

I have a zip-file with more info - web.config, code and so forth

http://dl.dropbox.com/u/4147808/LiveWriter-Error.zip

 

All help and tips are welcome.

 

/Stefan

 

 

#48964
Feb 24, 2011 15:32
Ted
Vote:
 

I would use Fiddler to see the requests and responses from the web server, "hopefully" at least one requests fails with an indication of why... :/

Is anonymous access allowed to the WLW manifest URL?

#48971
Feb 24, 2011 19:09
Vote:
 
#48979
Edited, Feb 25, 2011 1:16
Vote:
 

It looks like I get a "500" so next step is to understand why.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>500 - Internal server error.</title>
<style type="text/css">
<!--
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;} 
h1{font-size:2.4em;margin:0;color:#FFF;}
h2{font-size:1.7em;margin:0;color:#CC0000;} 
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} 
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
background-color:#555555;}
#content{margin:0 0 0 2%;position:relative;}
.content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;position:relative;}
-->
</style>
</head>
<body>
<div id="header"><h1>Server Error</h1></div>
<div id="content">
 <div class="content-container"><fieldset>
  <h2>500 - Internal server error.</h2>
  <h3>There is a problem with the resource you are looking for, and it cannot be displayed.</h3>
 </fieldset></div>
</div>
</body>
</html>

    

#48980
Feb 25, 2011 1:19
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.