Getting started: Wich version of Visual Studio

Vote:
 
I want to set up a development environment on my local computer just to try the things. I've understood that I need Microsoft SQL Server, so I've downloaded and installed Microsoft SQL Server 2005 Express.

I have also downloaded the Installation package for EPiServer CMS Software Development Kit, the CMS Manager and the DemoPackage.

Am I right so far?

I also need Visual Studio. I've understood that Visual Studio 2008 is not fully supported. Should I get Visual Studio 2005 instead? Is there any 60 day trial version of 2005? Can I use an Express version?

Is there anything more that I need?

Regards, Jon

#23945
Sep 18, 2008 22:45
Vote:
 

Provided that your're installing EPiServer CMS 5 (not version 4.x) using Visual Studio 2008 will not be a problem.

For more info, see the system requirements page.

#23957
Sep 19, 2008 8:28
Vote:
 
The SDK is not for VS2008 (yet?), but you dont really need that. Installa a fresh site with the Manager and install the sample public templates and off you go... 
#23959
Sep 19, 2008 8:39
Vote:
 

Also, installing the database from the Manager using SQL Server Express 2005 has given me headaches, but I do know that lots of people use it. The Visual Studio 2005 SDK installation uses that for new sites you create, so the limitations is with the manager.

I'm hoping that the new R2 version of CMS 5 will work better with the Visual Studio express editions (the CTP documentation says so anyway.) That would be a great way to get people started with EPiServer development.

If you have any, come see us on IRC (more info.)

/Steve

#23964
Sep 19, 2008 10:22
Vote:
 

A quick note, from CMS 5 R2, only Visual Studio 2008 SP 1 (including Express edition) is supported for development.

Read more on:

http://world.episerver.com/en/Articles/Items/EPiServer-CMS-R2---Features/ 

http://world.episerver.com/en/Documentation/Items/Tech-Notes/EPiServer-CMS-5/EPiServer-CMS-5-R2/System-Requirements/

/Steve

#23967
Sep 19, 2008 10:49
Vote:
 
I still have got some problems. When I try to install EPiServer CMS, it says "The toolbox controls installer package must be installed before you can install". What is The toolbox controls installer package?
#23994
Sep 19, 2008 21:58
Vote:
 

The toolbox installer is a little application to help integrate EPiServer and Visual Studio, you should run this before you run the VS installer.

/Steve

#24027
Sep 22, 2008 9:41
Vote:
 

I noticed that the toolbox installer dosn't come with the SP3 sdk. I'll look into that. But what you could do is to download the sdk for SP1 or 2 and use the toolbox installer from there.

 //Petter

#24032
Sep 22, 2008 11:36
Vote:
 

I found and downloaded a 90 days trial of Visual Studio 2005 (version 8.0.50727.42). First I installed the Toolbox installer (wich I found in the EpiserverCMS SP2 package), then VS and finally EpiserverCMS SP3.

I start VS and select File, New, Project. I select the EPiServer Project 5.1.422.267-template, but I get the error "The project file 'C:\Documents and Sett[...]\Temp\EPiServer8.csproj' cannot be opened. The project type is not supported by this installation."

Am I using the wrong version of VS, or did install the things wrong? 

#24056
Edited, Sep 22, 2008 22:58
Vote:
 

You need to install VS 2005 SP1. It includes the WAP model.

/Steve

#24075
Sep 23, 2008 13:26
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.