Disable PageFiles

Vote:
 

Hi.

Is it possible to disable PageFiles?

If it is not possible, can I set the Global Files folder to be the default folder in the FileManager?

BR,

Tore

#21256
Jun 24, 2008 11:59
Vote:
 

No unfortunately there is no way to disable the page files folder, but you can make any folder the default one by moving the VirtualPathProvider to the top of the list of providers in web.config.

#21261
Jun 24, 2008 14:14
Vote:
 

Hi Greger.

Thanks for yor reply. When I insert a picture form the Filemanager, I will always be prompted if want to make a folder for this Page if it has not been made already. Is there a way to disable this feature? I just want the Filemanager to open the default VirtualPathProvider.

BR,

Tore

#21267
Jun 24, 2008 16:24
Vote:
 

There is no way that I know. I've filed this as a bug as it would be logical for the dialog to work the same way as the "real" filemanager.

Bug #11530: The Select Image dialog always defaults to the page files folder 

#21316
Jun 25, 2008 17:31
Vote:
 
Has this been resolved in any of the released R1 Service Packs since? I can't find the Bug ID in the list.
#23768
Sep 16, 2008 0:03
Vote:
 
Hi Mårten.

I hoped it would be solved in SP3, but now it seems like EPiServer removed the bug from the buglist. Don`t know why they did that.

If you are tired of getting the message "A folder for this page has not been created, do you wish to create one now?", you can do a little change to the file createpagedirectory.ascx located under /uifolder/hosting/. You can disable the save button and alter the cancel button to look like a continue button. And alter the pagefoldernotcreated text to display "Please press ok to contine".

BR,

Tore

#23776
Sep 16, 2008 9:21
Vote:
 
Thanks for the quick comment and proposed workaround, Tore. Maybe this will be resolved in R2 due in a few weeks.
#23781
Sep 16, 2008 11:19
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.