Need help, kind of urgent

Vote:
 

I've just re-installed my computer at work with Visual Studio 2008 (with .Net Framework 3.5) and MS SQL Server 2005.

When installing  EPiServer CMS 5.1.422.4 I got the message that it was missing .Net Framework 3.0......

Ok, så I uninstalled .NET framework 3.5 and it's service pack, then installed .Net fw 3.0 and then .Net fw 3.5.

Right, that should do it. Let's try and install EPiServer CMS 5 again....

Bugger! Now the isntallation complaints that the following required components are missing....
- Visual Studio 2005 SP1
- SQL Server 2005 Express Edition
- .NET Framework 3.0

I really really do not wish to install VS 2005 or SQL Server Express edition.
I've isntalled both .NET Framework 3.0 and 3.5-

Any suggestions anyone? 

 

#20279
May 26, 2008 8:49
Vote:
 

The SDK install requires VS 2005 SP1. There is no installer for VS 2008 at this time. There will be one, but I do not know what date is set for it.

http://download.episerver.com/clickoncemanager/

I'm guessing you might be running Vista, and I'm not sure if the latest manager runs well on Vista, but in case it doesn't, Ruwen Jin wrote a guide  on how to install manually. http://labs.episerver.com/en/Blogs/Ruwen/Dates/112201/112202/Install-EPiServer-CMS-5-on-Vista/

#20285
May 26, 2008 11:14
Vote:
 

Thanks for the answer.

No, I'm still true to Windows XP :)

I don't need any integration with Visual Studio.
All I need is the ability to create new CMS 5 sites.

Installing VS 2005 is not an option as I do not (currently) hold a VS 2005 license.

I also do not want to install SQL Server Express when I already have installed the full SQL Server 2005.

And why does it say I need .NET Framework 3.0 when it has been isntalled?

Looks like the CMS 5 installer / manager it too tailored for a specific environment.

I should be able to install the EPiSerer Manager regardless of if I use SQL Server og express and regrdless of if I use VS 2003, 205 or 2008.

Does this mean that from now on I have to manually copy / paste files + manually run SQL script to create the DB?

 

#20291
May 26, 2008 12:24
Vote:
 

The manager should not require VS 2005 nor SQL Express (though SQL Express is supported).

Sounds like you are running the SDK installer for VS 2005, which will just tell you what it's prerequisites are, not which ones you are missing (as far as I know).

The EPiServer manager does not require installation and can be found here if you do not want the click once version mentioned above.

The manager should look some thing like this: manager.png

There have been issues in the past with different versions of the .net framework, but I just tried installing a new site with the latest manager with out any problems (having .net v3.5 installed).

#20402
May 28, 2008 10:47
Vote:
 
Aha!
I've been looking for this the past 4 months! :op

Thanks!
#20427
May 28, 2008 16:11
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.