How do I stop ampersands being escaped.

Vote:
 

I am trying to play a Flash video using an Object tag.

One of the Param tag's value attributes and the Embed tags flashvars attribute are an ampersand delimited string:

 e.g.

 

&MM_ComponentVersion=1&skinName=Corona_Skin_3&streamName=dh-corporate-video&autoPlay=true&autoRewind=true 

 

 The trouble is that when the page is rendered the ampersands are converted into & and this is casuing a problem with the Flash player.

I have placed this code in a EpiServer template, standard aspx page and a basic HTML page and it happens in all three.I am assuming that is it EpiServer doing this as if I run the standard HTML page from the filesystem the flash player works fine.

Anyone have any ideas?

 Thanks in advance.... 

 

#19930
May 14, 2008 17:28
Vote:
 

Hi Jim!

Without having access to your code I have two possible guesses.

  1. This value is stored in a string property. We will encode string properties when writing them to a page if you use the Property web control.
  2. The url rewrite module is rewriting these links. You could see if this is the case by setting the defaultProvider for the urlRewrite section in web.config to EPiServerNullUrlRewriteProvider. If also possible to register certain parts that will not be affected by the url rewrite provider, although I do not remember the exact code to do this.

Regards
Linus Ekström
EPiServer Development Team

#19944
May 16, 2008 11:44
Vote:
 

Hi,

It is definately the FriendlyUrlRewriteProvider that is modifying the URLs.

Is it possible to mark certain parts of the web page to not be rewritten? We need certain controls on the page to rewrite their URLs (e.g. convert them to friendly format) and certain parts to leave them alone.

To do this would we have to write our own provider?

Is it possible to extend the current FriendlyUrlRewriteProvider to allow us to filter out certain urls?

 Thanks,

 Jim.

#20797
Jun 12, 2008 15:45
Vote:
 

Hello Jim,

You could have a look at Ted Nybergs post on disabling URL rewriting for specific URLs. Fredrik Haglund also wrote a post where he disable it for a folder or file. And finaly Ruwen have a nice post on overriding EPiServer url rewrite behavior if that is what you should want.

Hope they will help.

/Petter

#20802
Jun 13, 2008 8:31
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.