Globalization culture=auto not working

Vote:
 

Hello,

I would like to set the <globalization culture="auto" uiCulture="auto" in web.config so that the cultureinfo is based on the users language preferences in the browser and not the current language in EPiServer.

For now no matter what I set the culture and uiCulture to in web.config the CultureInfo.CurrentCulture always returns en-US.

Can this be done? How come setting the culture & uiCulture to auto does not work?

#19801
May 06, 2008 16:53
Vote:
 

From the tech note "Globalization" (which can be found under the Documentation tab):

"If the web.config setting pageUseBrowserLanguagePreferences is true, then the language preference from the Web browser is used"

#19805
May 06, 2008 20:13
Vote:
 

Setting the pageUseBrowserLanguagePreferences=true does the trick as long as you are in View mode. As soon as I enter edit mode it switches back to en-US

Thank you for replying.

#19806
May 06, 2008 22:23
Vote:
 

Hi!

I tested this and it works fine for me in edit mode. You need to ensure that the users language setting is set to "Use system language" as the user language has a higher priority than the browser language(s) in the UI if defined.

Regards
Linus Ekström
EPiServer Development Team

#19810
May 07, 2008 10:15
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.