Running both 4.61 and 5

Vote:
 
Hi I get this error when I try to run an EPi 4.61 installation on my devlopment computer. Is There a way to run both version on the same computer? Typen EPiServer.Core.PageReference finns i både c:\WINDOWS\assembly\GAC\EPiServer\4.61.5.83__8fe83dea738b45b7\EPiServer.dll och c:\WINDOWS\assembly\GAC_MSIL\EPiServer\5.1.358.4__8fe83dea738b45b7\EPiServer.dll
#15765
Mar 25, 2008 19:07
Vote:
 
Hi, I've had the same problem. I think the manager works some Voodoo since it had added the version number of EPiServer CMS (5.1.358.4) to a tagPrefix mapping in one of the user controls. And that was on a project which at least I hadn't touched with the manager. Try searching the project for "5.1.358.4". Also, change the assembly bindings in web.config to redirect versions 4.* to 5.*. There could also be some junk in web.config added by the manager (I had it) so you might have to check that too... Regards, Magnus von Wachenfeldt
#16306
Mar 25, 2008 19:08
Vote:
 
.NET has something called side by side running, which means that you can run different versions of the same assembly(both exe and dll) on the same machine. If you don't specify which version do you want to run with, then 4.61 wil get confused when a new version gets installed. To avoid this you can do as Magnus suggested, and add the version string to your assembly refference. So instead of you can use, or whatever version for EPiServer 4.61 you have. Regards
#16307
Mar 25, 2008 19:08
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.