How do I go from 4.61 -> 5.0 RC3 ?

Vote:
 
1. Where can I find documentation on how to migrate from 4.61 to CMS (5.0)? 2. Can I directly upgrade from 4.61 to RC3, or do I have to go through RC1 and RC2?
#15735
Mar 25, 2008 19:07
Vote:
 
PS. I have had a look here: http://www.episerver.com/en/EPiServer_Knowledge_Center/Documentation/Release-Notes---EPiServer-CMS-5-RC3 It only explains on how to go from RC2 to RC3 and not how to go from 4.61 ot RC3.
#16251
Mar 25, 2008 19:08
Vote:
 
At the moment the migration from 4.61 to CMS 5 is a bit fuzzy so we don´t have any concrete documentation about this. Currently the procedure is something like this: 1. Make sure you have a working 4.61 with .NET 2.0 and masterpages (otherwise, upgrade to this level first). 2. Export the pages (if you want the entire site, export from the startpage) with the dependent PageTypes, the dynamic properties and Subscription tab (if you need it). 3. Install a EPiServer CMS 5 site. 4. Import the file into the root of this CMS 5 site. 5. Move your tempates and other related files from your 4.61 project to you CMS 5 project. 6. Compile. You are going to get alot of errors, some are just simple search and replace, and some functions you are going to have to rewite completely. There are still issues regarding the migration, a big one is for example the files and images that you, for the moment, need to upload to your CMS 5 site manually. But hopefully this is going to improve as we get closer to release. You should definatly NOT go through RC1 and RC2.
#16252
Mar 25, 2008 19:08
Vote:
 
Some additional information: We will begin looking on a content migration tool to move entire sites from EPiServer 4 to EPiServer CMS 5 as soon as we have get out the final release of EPiServer CMS 5. When this will be ready and what form it will have we do not know ourselves yet but more information about this is surely to be posted later this year.
#16253
Mar 25, 2008 19:08
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.