The EPiServer CMS Manager install problem

Vote:
 
Hi, I'm trying to install EPiServer CMS Manager on Windows XP prof sp2 using the link I received with email. When I start the installer it gives the following error: "Cannot Start Application" "Application download did not succeed. Check your network connection, or contact your system administrator or network service provider." Then on details it shows: ERROR SUMMARY Below is a summary of the errors, details of these errors are listed later in the log. * Activation of http://xxxxxxxx.xxxxxx.xxx/xxxxxxxxxxxxxx/xxxxxxxxx.xxxxxxxxx resulted in exception. Following failure messages were detected: + Downloading http://xx.xx.xx/xxxxxxxxxxxx/xxxxxxxxxx.xxxxxxxxx did not succeed. + The remote name could not be resolved: 'xx.xx.xx' (I replaced the real adress with xxxxxxs) When I tried the same on the machine without .NET Framework 3.0, clicking the same link just downloaded the .NET Framework 3.0 and installed it automatically, but then after rebooting, the same error than on the other machine. Any ideas how to fix this problem? Thanks in advance.
#15664
Mar 25, 2008 18:59
Vote:
 
I have the same problem. It seems that the click once installer tries to access the address t3.ep.se which cannot be resolved. Either the Click once installer must be updated to use an ip address or EPiServer provides the corresponding ip address so that we can change the hosts file to get it working. /René
#16086
Mar 25, 2008 19:08
Vote:
 
Hi! The problem was, as René points out, that the ClickOnce manifest pointed to another server that cannot be accessed from outside of our network. This problem has been fixed and you should now be able to download the Manager. Erik Skagerlind
#16087
Mar 25, 2008 19:08
Vote:
 
Thank You, now it worked. BUT, when I try to install EPiServer CMS site, at "Select Version" page it says: "Online installation is not available (no valid EPiServer versions could be found for download). I could choose the "Offline" with path to offline package. BUT when I try to launch "Create Offline Installation", the wizard pauses with error: "Unhalted exeption has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately. InvalidArgument=Value of '0' is not valid for 'SelectIndex' Parameter name SelectIndex." If I try to continue, nothing happens. Hope someone can help with this.
#16088
Mar 25, 2008 19:08
Vote:
 
It was something to do with demo/beta license. Now it is corrected at EPiServer CMS Manager so I can both install online and make an offline install package! Happy now :) Thank You Erik!
#16089
Mar 25, 2008 19:08
Vote:
 
I get this error message when running EPiServerManager.application: "Cannot download the application. The application is missing required files. Contact application vendor for assistance." The download of the file EPiServerManager.exe.manifest failed and that's what causes the error. Any solution to this problem? Thanks.
#16090
Mar 25, 2008 19:08
Vote:
 
Hi Martin! Is there no more information provided? Usually when an error occurs during the ClickOnce installation there's an option to view a more detailed error message. Probably this error has to do with the fact that the manager requires .NET Framework 2, do you have that framework version installed? In hindsight, maybe we shouldn't have provided a link pointing directly at the .application file, but rather just to http://download.episerver.com/clickoncemanager/. What happens if you visit that address? Do you get a message saying something about prerequisites? A comment comment on Jorma's problem: Yup, unfortunately we had published the RC1 version as a beta version but then we provided you (and everyone else) with a demo license via the registration form. But demo licenses aren't allowed to download beta versions... It has been fixed now! =)
#16091
Mar 25, 2008 19:08
Vote:
 
Hi Erik, thanks for your answer. This is the information provided: PLATFORM VERSION INFO Windows : 5.1.2600.131072 (Win32NT) Common Language Runtime : 2.0.50727.42 System.Deployment.dll : 2.0.50727.42 (RTM.050727-4200) mscorwks.dll : 2.0.50727.42 (RTM.050727-4200) dfdll.dll : 2.0.50727.42 (RTM.050727-4200) dfshim.dll : 2.0.50727.42 (RTM.050727-4200) SOURCES Deployment url : file:///C:/Documents%20and%20Settings/[username]/My%20Documents/downloads/episerver%20cms%20rc1/EPiServerManager.application IDENTITIES Deployment Identity : EPiServerManager.application, Version=2.0.5.3, Culture=neutral, PublicKeyToken=58dc57a1c62403a2, processorArchitecture=msil APPLICATION SUMMARY * Installable application. ERROR SUMMARY Below is a summary of the errors, details of these errors are listed later in the log. * Activation of C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager.application resulted in exception. Following failure messages were detected: + Downloading file:///C:/Documents and Settings/[username]/My Documents/downloads/episerver cms rc1/EPiServerManager_2_0_5_3/EPiServerManager.exe.manifest did not succeed. + Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. + Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. + Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. COMPONENT STORE TRANSACTION FAILURE SUMMARY No transaction error was detected. WARNINGS There were no warnings during this operation. OPERATION PROGRESS STATUS * [2007-05-03 11:11:43] : Activation of C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager.application has started. * [2007-05-03 11:11:43] : Processing of deployment manifest has successfully completed. * [2007-05-03 11:11:43] : Installation of the application has started. ERROR DETAILS Following errors were detected during this operation. * [2007-05-03 11:11:43] System.Deployment.Application.DeploymentDownloadException (Unknown subtype) - Downloading file:///C:/Documents and Settings/[username]/My Documents/downloads/episerver cms rc1/EPiServerManager_2_0_5_3/EPiServerManager.exe.manifest did not succeed. - Source: System.Deployment - Stack trace: at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next) at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles() at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState) at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation) at System.Deployment.Application.DownloadManager.DownloadApplicationManifest(AssemblyManifest deploymentManifest, String targetDir, Uri deploymentUri, IDownloadNotification notification, DownloadOptions options, Uri& appSourceUri, String& appManifestPath) at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp) at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState subState, ActivationDescription actDesc) at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut) at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state) --- Inner Exception --- System.Net.WebException - Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. - Source: System - Stack trace: at System.Net.FileWebRequest.EndGetResponse(IAsyncResult asyncResult) at System.Net.FileWebRequest.GetResponse() at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next) --- Inner Exception --- System.Net.WebException - Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. - Source: System - Stack trace: at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint) at System.Net.FileWebRequest.WrappedGetResponseCallback(Object state) --- Inner Exception --- System.IO.DirectoryNotFoundException - Could not find a part of the path 'C:\Documents and Settings\[username]\My Documents\downloads\episerver cms rc1\EPiServerManager_2_0_5_3\EPiServerManager.exe.manifest'. - Source: mscorlib - Stack trace: at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy) at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync) at System.Net.FileWebStream..ctor(FileWebRequest request, String path, FileMode mode, FileAccess access, FileShare sharing, Int32 length, Boolean async) at System.Net.FileWebResponse..ctor(FileWebRequest request, Uri uri, FileAccess access, Boolean asyncHint) COMPONENT STORE TRANSACTION DETAILS No transaction information is available.
#16092
Mar 25, 2008 19:08
Vote:
 
And yes, I have .NET framework 2.0 installed. I even have .NET framework 3.0.
#16093
Mar 25, 2008 19:08
Vote:
 
Hmm... It seems that you have downloaded the .application file and run it locally on your machine rather than running it "in place" on our server. Is that correct? What happens if you left-click this link to the application file: http://download.episerver.com/clickoncemanager/EPiServerManager.application
#16094
Mar 25, 2008 19:08
Vote:
 
If I left click the link a file save as popup box appears.
#16095
Mar 25, 2008 19:08
Vote:
 
Ok. There is obviously a problem in that the client does not now how to handle files with the .application extension. Check out the first paragraph in this troubleshooting guide: http://msdn2.microsoft.com/en-us/library/ms229001(VS.80).aspx I noticed that the our download server indeed did not have a mime-type mapping of the .application extension, so I have added that now. Should the problem still persist it has to be because of the settings on the client. Make sure that you have a file mapping for the .application extension (Control Panel -> Folder Options -> File Types tab).
#16096
Mar 25, 2008 19:08
Vote:
 
I have a file mapping for the .application file type. .application files are supposed to be opened by Application Deployment Support Library. I still have the same problem with the "save as" dialogue. I have uninstalled .NET framework 2.0 and installed .NET framework 3.0. What to do next? Thanks for your effort, Erik!
#16097
Mar 25, 2008 19:08
Vote:
 
Something a colleague just pointed out to me - are you using some other browser than IE? That would be an obvious explanation to what is happening, but it never occured to me until now. As far as I know this has been a known issue with ClickOnce for a long time and Microsoft's answer has always been "We're working on a solution in future releases". So, you'll just have to juse IE to install the Manager. I will look to update our downloadpage (which is now pretty stock) with information about this if we detect another user-agent that IE.
#16098
Mar 25, 2008 19:08
Vote:
 
Yes, I've been using Firefox. Actually, I tried IE a few days ago and encountered the same problem as I do now with Firefox. But when I tried IE now it all worked. I guess this is what solved the problem for me: - Uninstall .NET framework 2.0, install .NET framework 3.0 - Use IE when executing EPiServerManager.application Thank you very much!
#16099
Mar 25, 2008 19:08
Vote:
 
Can't install the latest version of the Manager using IE7. I get the error saying The remote name could not be resolved: 't3.ep.se' Something fishy with your network?
#16100
Mar 25, 2008 19:08
Vote:
 
...or, should I say, the manifest file for the latest Manager...
#16101
Mar 25, 2008 19:08
Vote:
 
Thanks, apparently someone has fixed the manifest now :)
#16102
Mar 25, 2008 19:08
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.