Problem: Installation Basic Content

Vote:
 
Hej! Jag har problem att komma vidare efter inloggningen när jag ska installera Basic Content. Jag har loggat in med ett lokalt adminkonto och när jag kommer till http://localhost:6666/EPiServer1/ui/admin/setup.aspx så får jag följande error: Server Error in '/EPiServer1' Application. -------------------------------------------------------------------------------- Object reference not set to an instance of an object. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.NullReferenceException: Object reference not set to an instance of an object. Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [NullReferenceException: Object reference not set to an instance of an object.] EPiServer.UI.WebControls.SystemPrefix.Render(HtmlTextWriter output) +282 System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25 System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22 System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130 System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24 System.Web.UI.Control.Render(HtmlTextWriter writer) +7 System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25 System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22 System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130 System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24 System.Web.UI.HtmlControls.HtmlForm.RenderChildren(HtmlTextWriter writer) +59 System.Web.UI.HtmlControls.HtmlForm.Render(HtmlTextWriter output) +68 System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25 System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121 System.Web.UI.HtmlControls.HtmlForm.RenderControl(HtmlTextWriter writer) +37 System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130 System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24 System.Web.UI.Control.Render(HtmlTextWriter writer) +7 System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25 System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22 System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +130 System.Web.UI.Control.RenderChildren(HtmlTextWriter writer) +24 System.Web.UI.Page.Render(HtmlTextWriter writer) +26 System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +25 System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter) +121 System.Web.UI.Control.RenderControl(HtmlTextWriter writer) +22 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1896 -------------------------------------------------------------------------------- Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210 Mvh Linda
#15650
Mar 25, 2008 18:58
Vote:
 
It is hard to say what's wrong. One reason might be that you have not placed your License-file in the project root (...\EPiServer1\EPiServer1). It should give you an other error message but it is worth checking. Also restart Visual Studio and create another new project (EPiServer2) and see if it behaves the same way. If you have not run the "skipverification.cmd" you should do so. One question is if this message occurs when you try to open the setup.aspx page the first time or if it occurs when you try to import your content. Is it the first or last case we are dealing with? If nothing else helps, you might try to manually change the attribute in "siteSettings" in web.config from 'pageStartId="0"' to 'pageStartId="1"'. This will tell EPiServer that you have installed your content even though you have not. When you get to the edit-mode you should add a start page manually and then again change the 'pageStartId' to the id that the new start page got.
#16051
Mar 25, 2008 19:07
Vote:
 
I had placed the License-file in the right catalouge and I had also run the the "skipverification.cmd". Therefore I tried to create an other project and this time it worked! I'm not sure what went wrong he first time. The error occured when I tried to log in so I didn't get to the page "Intall Basic Content" (step 12-13 in the guide "Creating and Buildning a New EPiServer Project"). Thanks for your help! /Linda
#16052
Mar 25, 2008 19:07
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.