User roles on installation

Vote:
 
When you install EPiServer CMS with EPiServer Manager 2.0, the only installation available is EPiServer 5.1.422.4 release. During the installtion, you are NOT asked to enter administrator username and password for EPiServer. By default, it uses roles defined in AD. This means that I will NEVER get administrator rights to EPiServer. According to EPiServer, one have to change the defaultProvider in web.config prior to your first login for a new installation. See answer here http://www.episerver.com/en/EPiServer_Knowledge_Center/Developer-Forum2/EPiServer-Developer-Forums-/EPiServer-CMS-version-5/14391/ I tried setting the defaultProvider to SqlServerRoleProvider. But that didnæ' work very well. All I want to do is to controll roles and users the good old fashion way; By defining roles and users in EPiServer. My question is; How can I do an installation that will NOT automatically use roles defined in out AD ?
#15922
Mar 25, 2008 19:07
Vote:
 
Hi Steven! Did you change the default provider for both membershio and roleprovider? They must be in sync. [...] Sincerly, Fredrik Haglund, INEXOR AB http://blog.fredrikhaglund.se
#16640
Mar 25, 2008 19:12
Vote:
 
Yes I tried that. Now when I open the site for the very first time, I get a login screen. But since I have not been able to register an adminsitrator username / password, I cannot log in.
#16641
Mar 25, 2008 19:12
Vote:
 
After enabling the SqlServerRole- and MembershipProvider you can use the ASP .Net Web Site Administation Tool to create users and roles/groups. You open this tool by clicking the ASP .NET Configuration button inside Visual Studio. Read more: http://www.developer.com/net/asp/article.php/3569166 MJ
#16642
Mar 25, 2008 19:12
Vote:
 
What is the purpose of Web Site Administation? Is that the only way of creating a EPiServer administrator user? I set roleManager to 'SqlServerRoleProvider' and membership to 'SqlServerMembershipProvider'. Then I opened the Web Site Administrator interface, and there where 0 users and 0 roles defined. So I created a role called "admin". In 'Create access rules' I sett Allow on the admin role. In web.config this results to: Then I create a new user ang give this user the admin role. Then I try to login, but it still does not work. When I set roleManager and provider to MultiPlexing, I can log in with normal user and I can see the user have been added to the system. But I still cannot login with this user and get admin rights. This is waaaaaay to complicated. I've been spending 2 weeks on trying to get admin rights to my site now. Why did you remove the section in the installtion where one can add admin user? Can you put it back please?
#16643
Mar 25, 2008 19:12
Vote:
 
The purpose of the Web Site Administation tool is to give access to Admin-mode in EPiServer if you dont have any registered members in your database and are only using SqlServerProvider. Look at this FAQ: http://www.episerver.com/en/EPiServer_Knowledge_Center/FAQ_EPiServer_4/1010/How-do-I-enable-SQL-Membership-Provider-for-my-site/ As it says in the FAQ you need to first create a user and then create a role for your user. Don't forget to add your user to the role. You don't need to create any access rules. You can do that manually in web.config. You do that by adding this role to the location section of web.config, as it says it the FAQ: To clarify, you dont need to add all text because most of it is already in the web.config. You just have to add your newly created role. Also, take in mind that the location path may differ depending on what you named your UI when you installed the site with the manager.
#16644
Mar 25, 2008 19:12
Vote:
 
Ah, it turnes out that is quite simple. 1. Upon installation it uses default WindowsRoleProvider / WindowsMembershipProvider. 2. In web.config switch to MultiplexingRoleProvider / MultiplexingMembershipProvider 3. If the roles WebAdmins and WebEditors are not created, create them and give them propper access rights. If they do exist, make sure they the provider is SqlServerRoleProvider. 4. In web.config switch to SqlServerRoleProvider / SqlServerMembershipProvider. 5. Now you should be able to login having admin rights which includes creating new users and giving them admin rights. Thanks for the help :)
#16645
Mar 25, 2008 19:12
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.