UrlRewriter and third party component I-Load

Vote:
 
Hello, I am using an "ImageVault-lite" type of application called "I-Load". The problem is that it will not work properly with EPiServers Friendly URL functionality, since I-Load like EPiServer utilizes an http module to create an .ashx file virtually when loading an image configuration modal dialog. The EPiServer UrlRewrite module effectively makes the I-Load virtual file not found. Has anyone encountered this kind of error before, and if so have a good solution/workaround for it? Regards, /Marten Berg
#15915
Mar 25, 2008 19:07
Vote:
 
Take a look at static property FriendlyUrlRewriteProvider.UnTouchedPaths There it is possible to specify paths that FURL module will leave untouched.
#16631
Mar 25, 2008 19:11
Vote:
 
Interesting, thanks for the information. However, I am having trouble getting it to work properly. I am defining this in Application_Start in global.asax: string path = "/templates/Intranet/Pages/ImageUpload/"; System.Collections.ICollection col = (System.Collections.ICollection)EPiServer.Web.FriendlyUrlRewriteProvider.UnTouchedPaths; lock (col.SyncRoot) { EPiServer.Web.FriendlyUrlRewriteProvider.UnTouchedPaths.Add(path); } And true enough, when I loop through the IList (System.Collections.IList)EPiServer.Web.FriendlyUrlRewriteProvider.UnTouchedPaths anywhere inside my app, I find the path in there. But EPiServer.Web.FriendlyUrlRewriteProvider.IsFurlEnabled still displays true when I am on a page inside the path, and the component does not still load properly. Am I doing something wrong? /Marten
#16632
Mar 25, 2008 19:11
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.