Wrong date format in subscription mail after upgrade to CMS 6 R2

Vibeke Randby
Member since: 2009
 

After an upgrade from CMS 6 to CMS 6 R2, the date format in the subscription mail was changed from [dd.MM.yyyy] to [M/d/yyyy]. No changes were made in regional settings on the server or in the globalization settings in EPiServer.

Where do the subscription function get this date format?

#65694 Feb 06, 2013 10:51
  • määäts
    Member since: 2010
     

    Hi!

    Guessing little here... EPiServers SubscriptionMail-class seems to use the "ToShortDateString()" method, and there is no difference between the CMS 6 & CMS 6 R2 versions as far as I can see.

    stringBuilder.Append(((DateTime)page[this._subscriptionMailDatePropertyName]).ToShortDateString());

    Can you check if the <globalization ...> section in web.config have been changed to "en" or "en-US"?  

    If so, is changing the culture-attribute to "nb-NO" or "nn-NO" solving your problem?

     

     

    #65869 Feb 12, 2013 16:59
  • Vibeke Randby
    Member since: 2009
     

    Thanks for the reply!
    No, the globalization section has not been altered by the upgrade. It is still "nb-NO".

    #65876 Feb 13, 2013 10:33
  • määäts
    Member since: 2010
     

    Hi again.

    I checked the SubscriptionJob-class and I think your problem is related to changes in the fallback-/replacement-language implementation. It seems the job  implementation is first trying to use the users (the recipients) language preferrence and then falling back to the EPiServer language settings.

    So my next guess would be:

    1) Check if the "Personal Language" setting for the user receiving the e-mail has changed.

    2) Check if the changed pages that triggers the subscription mail have the "Replacement language" set to "English". Some changes have been implemented here, see for example http://world.episerver.com/Blogs/Linus-Ekstrom/Dates/2011/3/Changes-to-the-EPiServer-CMS-Globalization/. I'm not sure if they apply to you. 

    Don't think I can help you further :)

    #65878 Feb 13, 2013 11:56
  • Vibeke Randby
    Member since: 2009
     

    Hi,

    Globalization is not activated for the site, so no replacement language is set. I checked one of the subscribers' personal language setting anyhow - it is still set to norwegian.

    #65889 Edited, Feb 13, 2013 14:07