Version Compare

 

Hi,

I've got 6.2 installed, and our client is trying to compare versions within the cms, however the compare button apparently does nothing.  I've done some further investigation and found it's returning a 404 error for the request to the item

/EPiServer/CMS/edit/PageCompare/AjaxCallPageCompare.aspx?first=27229_108184&second=27229_107901&panel=PageComparePanel&firstVersionNumber=31&secondVersionNumber=30

Any help would be appreciated. I've tried in all browsers etc, and get the same issue.

When the response is viewed in fiddler or firebug the following text is returned:

Incorrect link

The link you gave does not work, either because the page it points to has been deleted or moved. If you clicked on a link, please inform the site’s webmaster that the link is faulty.

Detailed error information (authorized by permissions to functions)

Error occured 2/19/2013 11:44:26 AM
User IP 127.0.0.1
User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Url http://localhost:6666/EPiServer/CMS/edit/PageCompare/AjaxCallPageCompare.aspx?first=27229_108184&second=27229_107901&panel=PageComparePanel&firstVersionNumber=31&secondVersionNumber=30
Referer http://localhost:6666/EPiServer/CMS/edit/EditPanel.aspx?id=27229

Exception details:

HttpException: Not Found

Http status:

404 NotFound

Stack trace:

[HttpException: Not Found]

#66063 Feb 19, 2013 12:52
  • Marcus Lindblom
    Member since: 2005
     

    To compare pages, EPiServer requires that the ContextMenu is enabled in Admin Mode > Config > Tool Settings > Plug-in Manager > EPiServer > Overview > Page Extensions > ContextMenu, the context menu also requires that you add runat="server" on the head tag of your html document.
    When you have made these changes, restart your site and you should be able to compare pages.

    #66088 Feb 19, 2013 21:36
  •  

    Hi,

    Thanks for the info, I've checked the settings and ContextMenu is enabled.  Also the head tag has a runat="server" attribute in it.  I am still getting a 404 on the request when clicking compare.  Have any further ideas?

    Cheers,

    Ian

    #66124 Feb 20, 2013 17:56
  • Marcus Lindblom
    Member since: 2005
     

    That's odd, did you reset the iis after you changed the contextmeu setting?

    #66125 Feb 20, 2013 18:01
  •  

    I didn't need to change the settings - but even after rebuilding (it's happening in my local dev environment as well as prod), it's just getting the 404.  I don't know if it ever worked - I never use it (and I am new to this particular project), and the client has only recently raised it that the "compare button does nothing"

    #66126 Edited, Feb 20, 2013 18:06
  • Marcus Lindblom
    Member since: 2005
     

    Ok, then I have run out of ideas.

    #66127 Feb 20, 2013 18:15