W3C Validator gets wrong version

Vote:
 

Hey,

I am trying to validate a site, and the validation errors I get doesn’t match the site that went online last year. 

It seems it validates a old cached version of the site, some of the errors is fixed and is not in the html markup anymore, so it shouldn’t still give an error.

Any suggestions to how to fix it? I can still validate with taking the html directly in, but this test should work for the link also.

 

I know this is maybe not a Episerver fault, but I can`t really find any other similare cases, so I will try here :)

#65462
Jan 30, 2013 13:51
Vote:
 

Hi,

What kind of errors do you get? If you're using a lot of webcontrols that renders html by them self, they're maybe render legacy html. Please see http://msdn.microsoft.com/en-us/library/x3k2ssx2%28v=vs.100%29.aspx. You can change this behaviour by updating your browser files and give the w3c bot more capabilities.

#65481
Jan 30, 2013 16:24
Vote:
 

Or even better; use webcontrols where you have full control over the html.

#65482
Jan 30, 2013 16:25
Vote:
 

There are a lot of user controls, I will try your suggestion and report back :)

#65667
Feb 05, 2013 10:33
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.