Currently edited by symbol in edit mode is always showing

 

In edit mode the symbol for "Currently edited by" (next to the page in the page tree) is always showing even though the page isn't currently edited. Any idea what I can do to make it work correctly?

Thanks!

#64930 Jan 16, 2013 13:40
  • Johan Petersson
    Member since: 2007
     

    There is a scheduled job in admin that removes currently edited pages.

    #64933 Jan 16, 2013 15:42
  • Johan Petersson
    Member since: 2007
     

    Maybe I should clarify that a bit, it doesn't remove the pages, but the status "Currently edited by".

    #64934 Jan 16, 2013 15:43
  •  

    I'm experiencing a similar issue, and I've run the scheduled job several times without success.

    Is there some way to resolve this with code, or perhaps setting some flag directly in the database?

     

    //Marcus

    #65926 Feb 14, 2013 15:29
  • Nicklas Lindblom
    Member since: 2007
     

    Any solution to this yet?

    #71205 May 14, 2013 10:42
  •  

    Hi!

    I've not found any solution on my own yet, Nicklas, and I've not seen any on EPiServer World either.

    #71208 May 14, 2013 10:55
  • Thomas Sløk Tvedt
    Member since: 2012
     

    Same problem here.. The scheduled job seems to work in the sense that i does delete data from the dynamic datastore (bigtable), and the InUseNotificationStore seems to update the cache properly... But still the currently edited by-icon is stuck in the pagetree :-( Even site-restart/clearing cache don't work. I thought maybe the editedby-status was cached somewhere else, but no change after resetting the site.

    Where can I find the code that decides to show/hide the icon in the pagetree? 

    #72889 Jul 02, 2013 12:47
  • Thomas Sløk Tvedt
    Member since: 2012
     

    For future reference, this was a known bug #91184 fixed in CMS 6 R2 (.502) (not tested yet if it works)

    #73446 Jul 22, 2013 12:03
  • Thomas Sløk Tvedt
    Member since: 2012
     

    Hmm, we're actually running version .502, and it still don't work :-(

    #73447 Jul 22, 2013 12:30
  • Thomas Sløk Tvedt
    Member since: 2012
     

    In addition to upgrade to version .502, I had to enable the scheduled job wich removes autosaved drafts :)

    #74124 Aug 21, 2013 9:30