Can't Save XForms after upgrading from CMS 5 to CMS 6 R2 (and .NET 4.0)

Vote:
 

After an successfull upgrade process from cms 5 to cms 6 r2, and switched to .NET 4.0. I get an error saving both existing and new xforms on my episerver site. There were no errors upgrading the XForms during the upgrade. But now I get this error when saving an XForm:

The typeBag and StoreDefinitionParameters passed along with the GlobalStoreDefinitionParametersMap for the store do not generate a matching store definition. See the Errors collection for more information.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: EPiServer.Data.Dynamic.StoreInconsistencyException: The typeBag and StoreDefinitionParameters passed along with the GlobalStoreDefinitionParametersMap for the store do not generate a matching store definition. See the Errors collection for more information.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[StoreInconsistencyException: The typeBag and StoreDefinitionParameters passed along with the GlobalStoreDefinitionParametersMap for the store do not generate a matching store definition. See the Errors collection for more information.]
   EPiServer.Data.Dynamic.StoreDefinition.InternalCreate(String storeName, IDictionary`2 typeBag, StoreDefinitionParameters parameters) +426
   EPiServer.Data.Dynamic.EPiServerDynamicDataStoreFactory.CreateStore(String storeName, IDictionary`2 typeBag, StoreDefinitionParameters parameters) +129
   EPiServer.XForms.XForm.Save() +259
   EPiServer.UI.Edit.XFormEdit.SaveForm(Boolean iClose) +326
   EPiServer.UI.WebControls.ToolButton.RaisePostBackEvent(String eventArgument) +265
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3707

This aplies to all existing xforms in the solution and new ones we try to create. Based on the stack trace I did some coding to debug this issue, and got hold of the Errors collection from the StoreInconsistencyException. It had one entry:

typeBag entry with name 'AllowMultiplePost' does not required an index but
the mapping with the same name does

Anybody knows what this means? And how it can be fixed?

(I have already tried this solution with no luck: http://world.episerver.com/Blogs/Paul-Smith/Dates1/2012/4/Problems-with-XForms-when-upgrading-to-CMS-6-R2/)

#63733
Nov 28, 2012 8:52
Vote:
 

Hi,

Can you please let me know if you were able to resolve this error. I'm facing the same issue for existing and new forms. Any pointers would be really helpful.

#66149
Feb 21, 2013 12:02
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.