ApplyEditChanges

Vote:
 

Hi, why wont it SAVE when using public override void ApplyEditChanges() but it will SAVE and PUBLISH?

#62947
Nov 05, 2012 18:27
Vote:
 
#62966
Nov 06, 2012 10:08
Vote:
 

Hi!

Could you give a bit more information on what is happening and what you are doing? The normal approach would be to set the value of the property in the ApplyEditChanges and that is not connected to either the save or publish. Save and/or publish that should be executed after all properties have updated their content.

#62975
Nov 06, 2012 10:55
Vote:
 

Hi, I have created a control using the details as described in Frederik Vig's Blog http://www.frederikvig.com/2010/05/episerver-custom-property-with-custom-settings/. It works well but the data in the EDIT view doesnt Save but it will if I click on the Save and Publish button. (I have used all the code as is)

I am fairly new to Episerver and this is my first attempt of a custom control so in not familiar with how the data is stored.

Thanks for your help,

Jon

#62983
Nov 06, 2012 11:09
Vote:
 

So clicking on the save-button does nothing? Normally save and save+publish would work the same way regarding saving the property with the only difference that publish also would publish the content. How are you checking that nothing has changed? Are you reloading the page by clicking on the page tree? If that is the case, you might want to be aware that EPiServer CMS 6 always selects the published version if there is a published version so clicking on the page tree would not load the updated property unless you select the new version specifically in the versions list.

#62984
Nov 06, 2012 11:16
Vote:
 

Hi,

Wow! It is working, thanks very much for pointing this out - probably has saved me another 4 hours of banging my head against a wall :).

Kind regards,

Jonathan

#62985
Nov 06, 2012 11:25
Vote:
 

Great! Could be good to know that the model has changed in EPiServer 7 so that we always load a common draft, ie your changed version, when you click on a page in the UI.

#62989
Nov 06, 2012 12:59
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.