LiveMonitor - Connection Failed 404 at VisitorsService.svc

Carlos Betancourt
Member since: 2011
 

Hi:
I am trying to use LiveMonitor but get a "Error. Connection failed, retrying - 404 Not Found - http://10.125.133.136/EPiServer/EPiTrace/services/VisitorService.svc"
I get this error after loading the LiveMonitor page.  I read in another thread that there were some issues when running LiveMonitor under SSL but as you can see in the error message in my case I am running under http.

I am running EPiServer under IIS 7.5

Thanks for the help.

#62371 Oct 23, 2012 14:15
  • Dmytro Duk
    Member since: 2008
     

    It looks like the service is not activated and that's why you get 404 error.

    Could you check if you have service activation handler defined for EPiTrace services location in web.config? Try to add following handler if you don't have it:

    <location path="EPiServer/EPiTrace/services">
      <system.webServer>
        <handlers>
          <add name="svc-Integrated-4.0" path="*.svc" verb="*" type="System.ServiceModel.Activation.ServiceHttpHandlerFactory, System.ServiceModel.Activation, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" preCondition="integratedMode,runtimeVersionv4.0" />
        </handlers>
      </system.webServer>
    </location>

        

    #62374 Oct 23, 2012 15:00
  • Carlos Betancourt
    Member since: 2011
     

    I didn't have the activation handler that you mentioned, but I still get the same error. Any other ideas what else can be wrong? Thanks

    #62379 Oct 23, 2012 16:41
  • Dmytro Duk
    Member since: 2008
     

    Well, you can also try to add static file handler in the end of that handlers list:

    <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />

        

    Another reason could be using multiple bindings on site, where Live Monitor is installed. Please check this article: http://world.episerver.com/Documentation/Items/Installation-Instructions/EPiServer-CMS/Version-6/EPiServer-CMS-6-R2/Installation-Instructions---Live-Monitor/

    You need following settings if you site is running ASP.NET 4:

    <configuration>
      <system.serviceModel>
        <serviceHostingEnvironment multipleSiteBindingsEnabled="true" ... />
      </system.serviceModel>
    </configuration>

        

    #62380 Edited, Oct 23, 2012 16:53
  • Eric
    Member since: 2007
     

    Are you have more than one bindin in IIS for you website? Since the live monitor is build on silverlight(WCF) you can not have more than on binding in IIS for you website. If you have more you need to specify them in web.config....

     

    Ooop sorry did not read the last part of the lates message... :) read the article!!

    #62385 Edited, Oct 23, 2012 22:37
  • Carlos Betancourt
    Member since: 2011
     

    I have two sites running in my EPiServer installation. But I am just testing live monitor with one of them, this means I have just made changes to one of the web.config files. Currently I am doing the tests locally in my computer. Therefore bindings should not be a problem, right? Since I can just call localhost. Anyways I tried adding the bindings problem mentioned in the article but it did not helped.


    I also tried the static file handler under:

    <location path="EPiServer/EPiTrace/services">
        <system.webServer>
          <handlers>
            <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />

        

     

    But then I got a different error, that the root node was not found or loaded. Any other ideas on how to find what is not working or misconfigured?  Thanks

    #62413 Edited, Oct 24, 2012 11:21
  • Eric
    Member since: 2007
     

    One thing you could try is to reinstall the .net-part for WCF. I think i have had that problem before as well. I do not think it is proper installed by default..!? Mayby the aspnet_regiis.exe -i command can help


    Also add this to web.config if you have not already done that?

    <serviceHostingEnvironment aspNetCompatibilityEnabled="true">
    <baseAddressPrefixFilters>
    <add prefix="http://appservices.DOMAIN.COM" />
    </baseAddressPrefixFilters>
    </serviceHostingEnvironment>

        

     

    #62414 Oct 24, 2012 11:32
  • Carlos Betancourt
    Member since: 2011
     

    I got stucked in other issues and had to stop the Live Monitor project, but now I am back and still have the same issue.

    I tried reinsalling it but no change. Regarding the section you mentioned, I read on Microsoft's site that it does not support "localhost", that I should use the "Full qualified machine name". How do I get this one?

    #65646 Feb 04, 2013 17:22