TinyMCE Upgrade Issue V6- V6R2

Vote:
 

We are getting the following error for all our dynamic content settings components that contains the TinyMCE control.

Object reference not set to an instance of an object. -   System.Exception {System.NullReferenceException}

at EPiServer.Editor.TinyMCE.Editor.OnPreRender(EventArgs e)

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Control.PreRenderRecursiveInternal()

   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

This happened immediately after the upgrade from 6 to 6.2 of EPiServer.

Any ideas about how to resolve this would be much appreciated.

Regards,

Robert Gibbins.

 

#52047
Jul 04, 2011 14:59
Vote:
 

Hi Robert!

I'm looking into a bug about the Tiny MCE web control throwing a null reference exception when used stand alone (that is: not a normal property in edit or on page edit mode). As far as I've seen, there was quite a rewrite of the set up for this control in order to handle the improved on page edit mode including support for Tiny MCE for CMS 6 R2. Unfortunately there does not seem to be a simple fix for this I we probably have to do some sort of rewrite of this. Perhaps you can use a client initiated Tiny MCE or a xhtml property until we do a fix?

#52071
Jul 05, 2011 9:26
Vote:
 

Hi Linus,

Have you ever worked on Mobile Apps in EPIServer CMS 6? Bcoz i am not getting the right link to do that. Recently i found one MobilePack software......but it is giving so many errors......

#52271
Jul 14, 2011 7:47
Vote:
 

Hi Robert!

I just ran into the same exception, after an upgrade, for the Tiny MCE control, did you find a solution?

/Kristoffer

#53173
Aug 30, 2011 16:22
Vote:
 

There's a hotfix available from EPiServer support. Just contact them.

/Erik

#53197
Aug 31, 2011 14:28
Vote:
 

Hi Erik,

IS there definitely a hotfix available? We contacted EPiServer but they have told us there is no fix available currently.

Thanks

Al

#54795
Nov 03, 2011 11:56
Vote:
 

YES there is.  It is the EPiServer.Data or EPiServer Assembly.  Pretty sure of it.  Tobias knows the exact assembly but I am almost certain it is EPiServer or EPiServer.Data you need to update.

I just confirmed that it is the EPiServer Assembly.  I ran into the same problem and uploaded the new EPiServer.dll to the gac on the server and WHALLA.  Works Like a charm

#54813
Edited, Nov 03, 2011 21:46
Vote:
 

Does the new v501 patch version contain this fix? Applied to a machine and still getting the same problem.

#58276
Apr 17, 2012 11:03
Vote:
 

Paul I think the 501 contains it. The latest general hotfix (502) has it at least.

Read more here:

http://world.episerver.com/Articles/Items/About-the-Latest-Updates-for-EPiServer-CMS-and-Relate/

#61197
Sep 11, 2012 15:07
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.