EditMode and IE9 problem

Vote:
 

EditMode is not shown completely in IE9 in both Browser and Document views. Since IE8 compatibility mode isn't an option because some CSS3 features aren't shown properly.

Is there any other advice beside to use another browser? :-)

#54436
Oct 14, 2011 15:19
Vote:
 

EPiServer CMS 6 R2 edit UI works with IE9 out of the box... What have you done? =)

#55453
Dec 02, 2011 1:19
Vote:
 

We have the same problem. When I open editmode in IE9, browser mode is set to ie9 and document mode to Quirks. Now the preview looks horrible, a lot of css not working. So I change the document mode to IE 9 standards and now the preview looks nice. But in this mode less than a quarter of the browsers height is used, so it looks hopeless. For example; the tree shows only root folder, recycle bin and the language selector. The rest is hidden in the scrollbar...

#56785
Feb 08, 2012 15:57
Vote:
 

Could open up the network tab in IE and check if any resources don't get loaded properly?

 

Frederik

#56786
Feb 08, 2012 16:34
Vote:
 

If you look at the markup that's sent out from Episerver edit interface, they embed a meta directive to force the browser into IE7 mode:

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

It seems this setting is ignored when I test in IE9 (overridden by smth else?), but if I force the browser to IE7/IE7Standards I can reproduce the mentioned behavior. I don't have an answer or solution, I just happened to noticed this suspicious little meta directive ;-)

#56788
Feb 08, 2012 16:41
Vote:
 

Hi!

Edit mode requires quirks mode to set up the layout for the different panels, what why the meta directive is there. We will move out of quirks mode for the next release but for now that's required to use edit mode.

Regards
Linus Ekström
EPiServer Development Team

#56794
Feb 09, 2012 7:38
Vote:
 

Ok, thanks for the info. When can we expect the next release? Hopefully our client won't upgrade to IE9 until then :-/

#56796
Feb 09, 2012 8:46
Vote:
 

I recall having your own x-ua-compatible in your templates will fix it for the preview frame...

Put this somewhere and you won't have to resolve to META-elements:
Response.AddHeader("x-ua-compatible", "ie=edge");

Edge will use the highest version and the "most standard" mode.

#56808
Feb 09, 2012 15:23
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.