Making a duplicate of live site, to work on development locally?

Vote:
 

Having been on the developer course, and built sites from within Visual Studio, I forgot to ask the trainer one question...

How can I make a duplicate of the live system, to work on locally within a VS episerver project?  Basically, I created a new project, and copied all the files from the live server, but ofcourse, much of the config relies on the host being connected to the domain.

I really just wondered how developers go about this?

Any advice would be very welcome. Thanks.

#50887
May 16, 2011 15:16
Vote:
 

Hi

I'm not sure what you're asking. Are you missing .cs files to put in your Visual Studio project or are the live site using for example Active directory provider and you have no access to the LDAP server?

In the first case you must of course get the files needed to compile the project. In the other case I usualy try to get the customer to provide a VPN connection so I can access what is needed. An other option is to get a virtual machine with the servers you need access to and run that machine localy.

Generally what you need is a local EPiServer site with the same version as the live server, a copy of the database and perhaps copys of the uploaded files/documents and a VS project that compiles and pehaps also other products that the live site uses.

Feel free to ask more if this is not what you was looking for...

/Henrik

#50896
May 16, 2011 19:45
Vote:
 

Hi Henrik,

thanks for the advise. Yes, I dont have access to the LDAP server, I have made a copy of all the web files, and alslo made a copy of the database to hold locally.  I think everything is as it should be, but ofcourse the config files are referencing non relevant data, such as the siteurl in episerver.config - in fact, having amended the siteurl to http://localhost:6666/projectName/ I am getting the error "The value for the property 'siteUrl' is not valid. The error is: The URL must be absolute"  Any ideas?

Thanks,

Jon

#50918
May 17, 2011 10:11
Vote:
 

Hi

I'm guessing here but I think you have to set the SiteURL to, in your case, http://localhost:6666/ instead of http://localhost:6666/projectName/

#50920
May 17, 2011 10:22
Vote:
 

Hi Henrik,

thank you for such a quick reply, but the site produces the same error - I understand your logic (as the siteID (in this case at least) holds the projectName), but projects I have created from scratch in VS before have always used localhost port 6666 (cassini running on this port), and then projectName... anyhow, I still recieving the error "The value for the property 'siteUrl' is not valid. The error is: The URL must be absolute" by removing the projectName from the siteUrl property. 

#50924
May 17, 2011 11:30
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.