Saving a page with Composer modules take a lot of time

Vote:
 

Our publishers are experiencing a really slow process during the save & publish phase, approximate 30 sec

We have noticed that this is only the case when dealing with pages using EPiServer Composer.

We have a lot of modules on certain pages ant these pages are really slow to save and publish.

We have compared with ordinary pagetype pages without modules and they are faster.

Our site is built with page type builder and EPiServer composer 4.0. running on a CMS 6.0

#49984
Apr 07, 2011 13:25
Vote:
 

Do you use CMO as well as Composer ?

#49986
Apr 07, 2011 14:55
Vote:
 

No we have built the web with Page type builder and EpiServer Composer.

#49996
Apr 08, 2011 8:19
Vote:
 

Did you find a solution to your problem ?

#57867
Mar 30, 2012 20:40
Vote:
 

We're experiencing a similar problem related to EPiServer Composer. Copying a composer block, or creating a global block, sometimes takes between 15-30 seconds.

Running EPiServer 6 R2 and Composer 4 R2.

#57876
Apr 02, 2012 8:42
Vote:
 

We have not found a solution to this, the issue has been forwaded to the EPiserver support and I guess the case is closed.

But we have done some database tracing and the amount of data request is inacceptable high!

I guess that you should try to keep the amount of modules in a page to a minimum.

 

 

 

#57877
Apr 02, 2012 8:46
Vote:
 

This is still ongoing for me EPiServer sent me their latest dll for composer with the following message although did not make matter's any better

"We could not reproduce this issue on any site using customer data, but the same problem happens with creating global block or Copying clipboard. Included is our latest Dropit.Extension dlls and SQL sproc fix performance issue of creating global block and Copying clipboard, you should please try to use the latest Dropit.Extension dll first, if no difference then use the SQL sproc fix"

 

#60332
Aug 06, 2012 11:33
Vote:
 

Hi Minesh,

What's the version of the Dropit.Extension dlls that they provided? We're using v4.1.0.142.

Would you know where I can get a copy of the SQL sproc fix performance?

We're having a similar problem wherein when you go to composer tab, it takes minutes for the home page to load. 3-5 minutes!

And it maxes out CPU utilisation on the server. It only happens on the home page. We were able to trace it and issues occurs as soon as dropit.extension.dll initialises composer.

#67884
Edited, Mar 14, 2013 0:48
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.