Problem with scheduler not running

Member since: 2004

The Scheduler is not running in one of our sites. It works well in dev environment, but not when deployed to live environment.

The only error message we are enable to come over is the following:

2011-02-17 20:56:16,350 ERROR [PipeServerChannel.ListenerMain] Microsoft.Samples.Runtime.Remoting.Channels.Pipe.DBG.Error - 18.3.1 Scheduler error: Unexpected exception caught and hidden Thread was being aborted.

Anyone who knows what causes this?

#48937 Feb 23, 2011 11:39
  • Seems like the service times out when trying to connect to or create the named pipe. enableScheduler="true" in episerver.config?

    If the service is not already running as Local System, try that.

     

    #48938 Feb 23, 2011 12:26
  • Member since: 2004

    Thanks for the response. The scheduler is set to run i web.config and we just noticed that several other sites on the machine works with scheduled tasks. The search goes on...

    #48954 Feb 24, 2011 13:22
  • Member since: 2008

    Hi,

    Have you tried to debug the scheduler?. Have a look at this blog post below:

    http://world.episerver.com/Blogs/Tobias-Nilsson/Dates/2010/12/Troubleshooting-the-Scheduler/

     

    #48958 Feb 24, 2011 14:10
  • Member since: 2004

    Yes, we've tried that. But we got it working by deleting everything in tblscheduleditem and tblscheduleditemlog and restarting the application.

    #48961 Feb 24, 2011 14:26
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
Please login to post a reply