Installing Live Monitor causes the site to stop functioning

Vote:
 

Hi,
installing Live Monitor - accordning to the instructions - causes the site to stop functioning.

The error message is as follows.

 

- - - - -

Could not load file or assembly 'EPiServer, Version=6.0.494.0, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Could not load file or assembly 'EPiServer, Version=6.0.494.0, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileLoadException: Could not load file or assembly 'EPiServer, Version=6.0.494.0, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:

[No relevant source lines]


Source File: c:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\root\f4e23bc3\a991d4b1\App_global.asax.uzo7h7y8.0.cs    Line: 0

Assembly Load Trace: The following information can be helpful to determine why the assembly 'EPiServer, Version=6.0.494.0, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' could not be loaded.

- - -

Heeeeelp, how can I solve this?
And what causes this?

Thanks in advance!

Ivar Johansson
Stockholm, Sweden

#42825
Sep 02, 2010 14:14
Vote:
 

The version it's looking for is not the CMS 6 RTM version (that ends in 530.0, not 494.0). So either livemonitor or your code is trying to load an old assembly for CMS 6. Does your web.config contain an assembly redirect for EPiServer.dll? If so, what does it look like?

#42847
Sep 02, 2010 20:30
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.