Globalization for dynamic properties

Vote:
 

How do i use globalization with dynamic properties?

In the settings for a dynamic property i have the following options:

Type, Name, Presenation control, Display in Edit Mode, Field Name, Help Text, Tab

"Unique value per language" is missing.

I installed the Demo Site and globalization seems to work there. However if I create a new property i get the same problem.

User Interface
#39819
Jun 02, 2010 12:51
Vote:
 

How does your web site languges setup look (admin mode -> Config - Manage Web Site Languages)? Which version of CMS are you using?

#39829
Jun 02, 2010 16:24
Vote:
 

Curious about this myself.. Have the same behavior on a freshly installed demo site running EPiServer CMS 6.

#39831
Jun 02, 2010 17:17
Vote:
 

Im using CMS 6 with two languages. Swedish first, then English.

#39844
Jun 03, 2010 8:36
Vote:
 

Hi!

This seems to be a bug and I have filed a bug report for this:

Bug #45891: Is Language Specific flag is not visible when editing dynamic properties

A work around until a fix has been released is to add the following code to the /ui/admin/editpagetypedfield.aspx file:

<script runat="server">
protected override void OnLoad(EventArgs e)
{
base.OnLoad(e);
PageTypeOnly.Visible = true;
}
</script>

This will enable some more fields than just the language specific field but I tried it and it seems to work.

Regards
Linus Ekström
EPiServer Development Team

#39845
Jun 03, 2010 8:47
Vote:
 

I tried the workaround that was suggested in the post above and it works great. But I saw that this solution is from June and I was wondering if there is a hotfix or some other fix for this bug so that I don't have to do this again of I update CMS 6?

#45995
Nov 24, 2010 11:04
Vote:
 

Hello,

The next release should have the fix included so you won't have to manually make the fix again :)

#45996
Nov 24, 2010 11:41
Vote:
 

Hi! Thanks for quick answer and you have a very good point there. :P

#45997
Nov 24, 2010 11:42
Vote:
 

I cant find this file. Where is it located? (editpagetypedfield.aspx)

#172731
Dec 09, 2016 12:02
Vote:
 

Olivia try the same approach Jon D Jones used in his blog post to replace one of the built in login images:

http://jondjones.com/how-to-change-the-image-and-logo-on-the-log-in-page-in-episerver-9/

Redirect the request to editpagetypefield.aspx to an aspx in your project.

/T

#172734
Dec 09, 2016 12:51
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.