[CTP2] BUG: Register Web Parts does not compile

Vote:
 
Steps:
* Make a clean install
* Go to admin mode
* Click Register Web Parts

Compiler Error Message: CS0234: The type or namespace name 'Wsrp' does not exist in the namespace 'EPiServer.WebParts.WebControls' (are you missing an assembly reference?)

Source Error:

Line 1: <%@ Page Language="C#" AutoEventWireup="true" Codebehind="WebPartAdminEdit.aspx.cs" Inherits="EPiServer.WebParts.UI.Admin.WebPartAdminEdit" MasterPageFile="../MasterPages/EPiServerUI.Master" %>
Line 2: <%@ Register TagPrefix="webparts" Namespace="EPiServer.WebParts.WebControls.Wsrp" Assembly="EPiServer" %>
Line 3:
Line 4:


Source File: /secure/UI/admin/WebPartAdminEdit.aspx Line: 2


http://server/secure/UI/admin/WebPartAdminEdit.aspx(2,42): error CS0234: The type or namespace name 'Wsrp' does not exist in the namespace 'EPiServer.WebParts.WebControls' (are you missing an assembly reference?)

 

Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927

#33752
Oct 19, 2009 21:27
mg
Vote:
 

Thanks for the report, this is probably due to the fact that WSRP has been changed a bit to be released as a separate add-on/module for CMS 6.

 

Mattias Nordgren
Product Manager EPiServer CMS

#33790
Oct 20, 2009 12:09
Vote:
 

Hi!

 We have a bug report for this problem although it is currently tagged as internal. My guess for this is that it was considered as an internal problem until we released the EPiServer CMS 6 CTP 2 release.

Bug #11511: The Webpart UI in admin is broken.

Regards
Linus Ekström
EPiServer Development Team

#33797
Oct 20, 2009 12:13
Vote:
 

Hi Linus,

http://tedgustaf.com/en/blog/2008/8/using-web-parts-in-episerver/

I developed a webpart based on the procedure stated in the above url..........everything works fine......but along with Delete,Mininmise........Edit option is not displaying......Can u figure out this issue?

#52399
Jul 21, 2011 13:24
Vote:
 

Sorry Murali but I'm not very skilled in the web parts technology so I can't help you with this.

#52459
Jul 27, 2011 17:55
Vote:
 

Its ok Linus.......thanks for your reply......i will search in some other regions......

#52464
Jul 28, 2011 8:57
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.