Problems with load balanced site

Vote:
 

Hi,
We have a site running EPiServer CMS 5 R2 SP 2 on two servers. However the cache synchronization isn't working as supposed. I have read the article “Cache Update and Load Balancing for EPiServer CMS 5” (http://world.episerver.com/Articles/Items/Cache-Update-and-Load-Balancing-for-EPiServer-CMS-5/) without any new ideas to the source of the problem.
I have also used the “EPiServer Remote Event Listener”-tool and can see that events is correctly sent and received by the other machine when I publish a page in EPiServer. The problem is that the cache isn’t invalidated on the second server.
Any suggestions for how to proceed with the troubleshooting is highly appreciated. =)
Regards,
Karl

Hi,

We have a site running EPiServer CMS 5 R2 SP 2 on two servers. However the cache synchronization isn't working as supposed. I have read the article “Cache Update and Load Balancing for EPiServer CMS 5” (http://world.episerver.com/Articles/Items/Cache-Update-and-Load-Balancing-for-EPiServer-CMS-5/) without any new ideas to the source of the problem.

I have also used the “EPiServer Remote Event Listener”-tool and can see that events is correctly broadcasted and received by the other machine when I publish a page in EPiServer. The problem is that the cache isn’t invalidated on the second server.

Any suggestions for how to proceed with the troubleshooting is highly appreciated. =)

Regards,Karl

#42789
Sep 01, 2010 14:05
Vote:
 

Hi Karl,

What IIS are you running on 6 or 7? Also are you using the udp protocol for sending the packages?

#42790
Sep 01, 2010 14:32
Vote:
 

Make sure both servers use the same value for the siteid attribute in site settings in web.config (episerver.config in CMS 6)

#42791
Sep 01, 2010 14:47
Vote:
 

Thanks for your replies!

The sites are runnin on a Windows 2008 server with IIS 7 in Integrated Pipeline Mode, the udp protocol is used for sending the packages (enableRemoteEvents is set to true and endpoints are configured to send/receive using udp under system.serviceModel).

I have also double checked so the siteId-attribute is the same on both servers.

#42809
Sep 02, 2010 8:35
Vote:
 

Hi Karl,

As your using the Integrated Pipeline Mode the EventSubscriberHostModule that you added according to the article will not be used. instead you need to add this under your module tag.

<system.webServer>

 <modules runAllManagedModulesForAllRequests="true">

<add name="EventSubscriberHostModule" type="EPiServer.EventSubscriberHostModule, EPiServer" />

 

#42812
Sep 02, 2010 9:41
Vote:
 

All http handlers and modules are registered under the system.webServer section so that shouldn't be the problem. The runAllManagedModulesForAllRequests-attribute is set to true as well...

Any other ideas?

#42816
Sep 02, 2010 11:28
Vote:
 

No running out of ideas. Are you able to post your web.configs for the two servers?

#42821
Sep 02, 2010 11:42
Vote:
 

The web.config-files is identical on the two servers, a copy of the file is avaiable at http://pastebin.com/S60A85UL.

#42823
Sep 02, 2010 13:14
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.