web dialog for property type: URL to page/external address looks strange in CMS 5 R2

Dominik Juszczyk
Member since: 2006
 
Hi,

I have strange behavior of dialog of property type: URL to page/external address (CMS 5 R2).

I have added dynamic property of this type, and then I tried to define its value in edit mode. When I clicked button dialog is opened but is missing one part (that one with target frame, clickable text etc).
But when I open this dialog pasting its (dialog) URL in the browser I can see both parts of the dialog. I noticed this behavior on two separate CSM 5 R2 installations.

Screenshots:

 Dialog opened from edit mode:

 http://blog.juszczyk.biz/files/screenshot_1.png

Dialog opened with direct URL (to the dialog) pasted to the browser:

http://blog.juszczyk.biz/files/screenshot_2.png 

 

Do you have any ideas how to make this dialog looks correct?
Thank you in advance for any help 
Regards,
Dominik

#28673 Mar 18, 2009 8:57
  • Mari Jørgensen
    Member since: 2003
     
    Seems like this is the default behavior of the property type. Not sure why options such as clickable text and target are hidden by default.
    #28676 Mar 18, 2009 9:49
  • Steve Celius
    Member since: 2001
     

    In the first screenshot, the dialog is opened from the url property, which will hold the url. Where would you store the target and link text in that property? :-)

    "By design" is probably a good statement here.

     /Steve 

    #28686 Mar 18, 2009 12:13
  • Mari Jørgensen
    Member since: 2003
     
    Good point, Steve Cool
    #28687 Mar 18, 2009 13:13
  • Dominik Juszczyk
    Member since: 2006
     

    Thank you Mari and Steve for answers.

    I have checked how it was in EPiServer 4.6x and there those properties are visible but not enabled.

    I'm checking it because customer claims that they had such possibility (define target frame) before migration. Apparently they had not.

    Best regards,

    Dominik

    #28690 Mar 18, 2009 13:39