"Express" is greyed out in the installer

 

I want to install EPiServer CMS 5.2.375.7 with the example web site and database. But the installer only has "Application Files" and "Custom" clickable; "Express" is greyed out. And when I go into "Custom", only "Core Files" and "Public Templates" are available - there's no "Example Site" listed.

I see the link to the blog post for doing an express installation from a command prompt, but that page says it requires SQ Server installed locally. My SQL Server is on the network.

How do I get the example site installed?

 

#26874 Jan 06, 2009 16:58
  •  
    The application files includes a tool called "EPiServer Installation Manager". It should be available from the start menu. Run it and choose to install a site with database from the options. In the wizard select public templates.
    #26875 Jan 06, 2009 21:10
  •  

    I tried this just now (using "Install Site (SqlServer)"), but the install failed with "Error - This access control list is not in canonical form and therefore cannot be modified." I didn't set up an access control list in the wizard...

    Here's the log from the installer window:

    Copied connectionStrings.config
    Copied default.htm
    Copied EPiServerLog.config
    Copied FileSummary.config
    Copied global.asax
    Copied web.config.6
    Copied web.config.7
    Copied AdapterMappings.browser
    Copied IE6.browser
    Copied contentChannelText.xml
    Copied languageDA.xml
    Copied languageDE.xml
    Copied languageEN.xml
    Copied languageES.xml
    Copied languageFI.xml
    Copied languageFR.xml
    Copied languageJA.xml
    Copied languageNL.xml
    Copied languageNO.xml
    Copied languagePT.xml
    Copied languageSV.xml
    Copied languageZH.xml
    Copied newtext.xml
    Copied newtext_sent_to_translation.xml
    Copied workflowFoundation.xml
    Copied workflowFoundation_DA.xml
    Copied workflowFoundation_DE.xml
    Copied workflowFoundation_EN.xml
    Copied workflowFoundation_ES.xml
    Copied workflowFoundation_FI.xml
    Copied workflowFoundation_FR.xml
    Copied workflowFoundation_JA.xml
    Copied workflowFoundation_NL.xml
    Copied workflowFoundation_NO.xml
    Copied workflowFoundation_PT.xml
    Copied workflowFoundation_SV.xml
    Copied workflowFoundation_ZH.xml
    Copied ElektroPost.Licensing.dll
    Copied EPiServer.BaseLibrary.dll
    Copied EPiServer.Configuration.dll
    Copied EPiServer.dll
    Copied EPiServer.Enterprise.dll
    Copied EPiServer.Events.dll
    Copied EPiServer.ImageLibrary.dll
    Copied EPiServer.Implementation.dll
    Copied EPiServer.Legacy4.dll
    Copied EPiServer.Log.Analyzers.dll
    Copied EPiServer.Log.Core.dll
    Copied EPiServer.Lucene.dll
    Copied EPiServer.Providers.Oracle.dll
    Copied EPiServer.Scheduler.dll
    Copied EPiServer.Scheduler.WKTL.dll
    Copied EPiServer.UI.dll
    Copied EPiServer.Web.WebControls.dll
    Copied EPiServer.WebDav.dll
    Copied EPiServer.WorkflowFoundation.dll
    Copied EPiServer.Wsrp.dll
    Copied EPiServer.XForms.dll
    Copied log4net.dll
    Copied Microsoft.Web.Services3.dll
    Moved web.config.7 to web.config
    Removed web.config.6
    System.InvalidOperationException: The installation failed, and the rollback has been performed. ---> System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
    at System.Security.AccessControl.CommonAcl.ThrowIfNotCanonical()
    at System.Security.AccessControl.CommonAcl.SetQualifiedAce(SecurityIdentifier sid, AceQualifier qualifier, Int32 accessMask, AceFlags flags, ObjectAceFlags objectFlags, Guid objectType, Guid inheritedObjectType)
    at System.Security.AccessControl.DiscretionaryAcl.SetAccess(AccessControlType accessType, SecurityIdentifier sid, Int32 accessMask, InheritanceFlags inheritanceFlags, PropagationFlags propagationFlags)
    at System.Security.AccessControl.CommonObjectSecurity.ModifyAccess(AccessControlModification modification, AccessRule rule, Boolean& modified)
    at System.Security.AccessControl.CommonObjectSecurity.SetAccessRule(AccessRule rule)
    at EPiServer.Install.FileSystem.Installers.SetAccessRightsInstaller.Install(IDictionary stateSaver)
    at System.Configuration.Install.Installer.Install(IDictionary stateSaver)
    at System.Configuration.Install.TransactedInstaller.Install(IDictionary savedState)
    --- End of inner exception stack trace ---
    at System.Configuration.Install.TransactedInstaller.Install(IDictionary savedState)
    at EPiServer.Install.InstallationManager.DoInstall()
    Error - System.Management.Automation.CmdletInvocationException: This access control list is not in canonical form and therefore cannot be modified. ---> System.InvalidOperationException: This access control list is not in canonical form and therefore cannot be modified.
    at EPiServer.Install.InstallationManager.DoInstall()
    at EPiServer.Install.InstallationManager.CommitBulkInstall()
    at EPiServer.Install.Common.Cmdlets.CommitBulkInstallCmdlet.ProcessRecord()
    at System.Management.Automation.Cmdlet.DoProcessRecord()
    at System.Management.Automation.CommandProcessor.ProcessRecord()
    --- End of inner exception stack trace ---
    at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
    at System.Management.Automation.Parser.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)
    at System.Management.Automation.Parser.StatementListNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)

    #26903 Jan 07, 2009 16:23
  •  

    The error occurs when the installation process is about to set permissions for the worker process account and inet user on the site folder and the VPP folders (uploaded files). Some googling indicates that the error is caused by corrupted permission entries and a lot of hits refers to the use of NewSid [http://technet.microsoft.com/en-us/sysinternals/bb897418.aspx].

    Here's another forum post describing a similar problem, but in the registry. http://forum.sysinternals.com/forum_posts.asp?TID=6260 

    Is it by any chance a cloned machine you are testing on?

    #26915 Jan 08, 2009 9:27
  •  

    This happends in a WM Ware (mirrored configuration) environment. If you are running Windows XP you can fix this by adding the ASP.Net user account access rights on the folder c:\episerver\sites. Remember to choose Advanced and Replace permissions entries on child objects.

    #33779 Oct 20, 2009 10:57
  • Christoffer Nordling
    Member since: 2006
     

    got this problem when trying to install a episerver 6 R2 and the problem was that the vpp folder was in the same folder as the site. Made a new vpp folder outside of inetpub and it worked.

    #53996 Sep 28, 2011 16:14
  • ben
     

    I also had this problem when I was trying to install the Database and site from EPiServer Deployment Manager. 

    I do not know how to resolve it. I have tried the above solutions but still the same issue. 

    #69164 Mar 25, 2013 2:13
  • ben
     

    Error - This access control list is not in canonical form and therefore cannot be modified.

    #69165 Mar 25, 2013 2:15