Problems with friendly URL's

Vote:
 

When deploying a new site which is using CMS 5 R2 we're experiencing problems getting the url-rewriting to work.

We've set up the site as we've done with previous CMS 5 sites that got friendly url's working just fine.

Anyone else experienced this problem with the R2-version? I've noticed there are some differences in web.config for this version - do we need to set up stuff differently?

Here are a few lines from the debuglog:

2008-10-06 12:13:46,750 DEBUG [1] EPiServer.Web.UrlRewriteModuleBase.BeginRequestEventHandler - Starting request with Url http://web.testdomain.no/Util/Notfound.aspx?404;http://web.testdomain.no:80/en/International/Person/
2008-10-06 12:13:46,750 DEBUG [8] EPiServer.WorkflowFoundation.Services.CommunicationService.SendEventsOnThread - 21.5.5 Event dispatcher thread started
2008-10-06 12:13:46,750 DEBUG [1] EPiServer.Web.UrlRewriteModule.HttpUrlRewriteToInternal - Url is not valid for rewrite. Returning URL http://web.testdomain.no/Util/Notfound.aspx?404;http://web.testdomain.no:80/en/International/Person/
2008-10-06 12:13:46,765 DEBUG [1] EPiServer.Web.UrlRewriteModuleBase.BeginRequestEventHandler - Exiting with no rewrite, Url is http://web.testdomain.no/Util/Notfound.aspx?404;http://web.testdomain.no:80/en/International/Person/
 
#24725
Oct 06, 2008 15:06
Vote:
 

It looks like you haven't configured the wild card mapping, did you install this site manually or using the installation manager ?

 

#24730
Oct 06, 2008 15:53
Vote:
 

Hi, the site was installed manually.

Wild-card mapping has allready been added in IIS for the website (directing to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll).

Btw, this is installed on a Windows Server 2003 with SP2 running IIS 6.

#24735
Edited, Oct 06, 2008 18:13
Vote:
 
Ok, did you uncheck "Verify that file exists" when adding the wild card mapping ?
#24740
Oct 07, 2008 9:27
Vote:
 
Thank you. Unchecking that one did the trick. :)
#24742
Oct 07, 2008 10:10
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.